Skocz do zawartości
picasso

Przerwa techniczna - konwersja bazy

Rekomendowane odpowiedzi

W związku z edycją w poprzednim wątku: KLIK. Dziś zostanie przeprowadzony ten proces na prawdziwym forum.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu: klik.

Konwersja bazy wykonana. Forum ma ujednolicone kodowanie tabel, w 100% UTF-8. Odbyła się też hurtowa wymiana polskich fontów wprost w bazie. Na tyle na ile sprawdziłam, wszystkie części forum mają poprawne ich wyświetlanie. Natomiast mogą się zaplątać znaki z innych języków (typu umlaut etc.) wklejane przez Was w postach, które po konwersji będą wyświetlane jako "uszkodzone". Rzecz jasna te znaki ominięte przy konwersji, bo to ułamek procenta forum.
Przy okazji, ujednolicenie kodowania zlikwidowało na dobre ten bug ujawniony po zmianie serwera, który Luuk rozwiązał wtedy siłowym hackiem mającym skutki uboczne (brak podświetlania znalezionego tekstu): KLIK.

Długo nam zeszło, bo sprawdzaliśmy wszystko dokładnie (robota sapera), została zrobiona także aktualizacja do najnowszej wersji forum i było dużo weryfikacji. Wątek aktualizacyjny omawiamy w innym temacie: KLIK. Natomiast w tym temacie proszę zgłaszać ewentualne wychwycone pojedyncze krzaki w postach.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

ja widzę że przy pisaniu odpowiedzi pole tekstowe zamiast znakczków stosuje graficzne ich zastąpienie co fajnie wygląda

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

U mnie nic takiego nie występuje. Jakie masz ustawione kodowanie strony w przeglądarce?

 

Przy okazji: kieruję do wątku o Aktualizacji forum = cache musi zostać wyczyszczone.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Zamiast ł jakies krzaczki na screenie widać(pasek adresu)

"Ogłoszenie" dziwnie to wygląda testowałem i na IE może to u mnie coś tak nie wygląda za dobrze ?

514e27f4d39fe.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Poprawię to (problem ogólnie w tytułach ogłoszeń). Ale już nie dziś. Jestem zbyt zmęczona.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

U mnie nic takiego nie występuje. Jakie masz ustawione kodowanie strony w przeglądarce?

 

Przy okazji: kieruję do wątku o Aktualizacji forum = cache musi zostać wyczyszczone.

 

mam domyślne a cache poszło po resecie bo pdf się pobierały zamiast włączać - nie zależnie czy to wtyczka adobe czy foxit czy HTML5+JS miało go wyświetlać jeszcze jedno w temacie o jave 8 jest coś takiego https://www.fixitpc.pl/topic/16507-java-czym-jest-80-build-77-preview/

 

JDK™ 8 Early Access Releases = 8 Build b77 to wczesna wersja rozwojowa a nie stabilna.

 

chodzi mi o te znaki po a z daszkiem po ciemną 8 nie było nic takiego

 

to z kodami "quote" wstawiane z panelu wyglądają jak na obrazku podczas pisania

jak dla mnie to uławia pisanie i powinno być w edytorze więcej takich rzeczy

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

A, to zupełnie inaczej sobie wyobraziłam te "grafiki" (trójkąty i podobne zamiast polskich ogonków). To jest to o czym mówię: znaki spoza polskich (fonty z innych języków oraz znaki specjalne = w tym przypadku ) mogą być uszkodzone.

 

To od ręki zedytowałam. Natomiast to co zgłaszał Conor29134 (URL ogłoszeń) to dopiero jutro, bo mimo iż pozornie ręcznie mogę zedytować tytuł, należy zapuścić dla pewności hurtową komendę konwersyjną. Polujcie na te krzaki.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

nie wiem co robię źle ale jak edytuje posta to zmieniają mi się polskie znaki na encje

 

Problem 1. ręcznie poprawiłam

 

 

wszystkie skróty mam po Polsku w panelu sterowania a ten jeden jest zdublowany jest po angielsku... to wiem z #1 posta, chodziło mi czy jak włączysz zdublowaną opcje to włączy polskie okienko
tak aby było bezpiecznie to zrób punkt kontrolny systemu
i spróbuj tak


kiedyś to kod sformatowany zamiast w bb (listy) robiły się w html i wyświetlała się brzydka lista z tagami

jak poprawiam i daję zapisz to po chwili wraca zapis z encją - litery Ó ó edytor nie lubi

 

 

Problem 2. https://www.fixitpc.pl/topic/17163-zawieszanie-się-przeglądarki-i-blue-screen-na-mini-minipl/?p=116389

 

 

 

Firefox > Pomoc > O programie Firefox

lub

Pomoc > O programie Firefox

 

tu wyjątkowo nie lubi >

 

no to się doigrałam mam błąd https://www.fixitpc.pl/topic/17164-jak-usunąc-ikone-w-panelu-sterowania-xp/?p=116394

 

Problem 3.

 

<p>no u mnie na XP to mam też dużo opcji jak opisujesz więc to polskie było by OK. Nie wiem co będziesz musiał zrobić by dojść co zrobiło / jak usunąć tą pozycję angielską</p>
<p> </p>
<p>może angielska nie ma więcej bo brak plików z angielski mui?</p>

 

pojawiły się znaki html i błąd z ó tego już dzisiaj nie poprawiam

ten błąd to chyba leży po stronie klienta forum

Edytowane przez Kate

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Conor29134
 
Adresy ogłoszeń poprawione.
 
 
Kate
 
Znaki typu nie powinny stanowić żadnego problemu, ani moje stare posty sprzed zmian (np. KLIK), ani nowe nie wykazują błędów. Te wszystkie opisane efekty z widzialnymi znacznikami HTML i encjami występują, jeśli zastosujesz przycisk przełączania trybów edytora ckeditor_switch.png, ale nie odświeżysz otwartych stron, które miały ustawiony inny tryb niż przed przełączeniem. Przykładowy scenariusz: otwarta karta i ustawiony tryb WYSIWYG, otwierasz kolejną kartę i w niej przestawiasz edytor na tryb BBCode, wracasz do pierwszej karty i próbujesz postować = edytor nie jest świadomy, że przełączono tryby w innej karcie i zwraca sieczkę. To nie jest efekt specyficzny dla tej wersji forum, był od zawsze na CKEditor. Taki post jest już definitywnie źle zapisany i należy go ręcznie poprawić. Poprawiłam te linkowane.
 
Tak więc: czy przestawiałaś tryby edytora?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

raczej sam się włączał w bbc i bez górnego paska na błękitny tle była treść pisana arialem z podglądem bbc nijak podobna do przyciskowej funkcji z panelu

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Co oznacza "bez górnego paska": menu wyciemnione (nieklikalne kontrolki) czy zupełny brak menu z kontrolkami?

 

- Pierwszy przypadek: został jednak ustawiony tryb BBCode przyciskiem zmiany trybu.

- Drugi przypadek: albo cache przeglądarki niedobrze wyczyszczone albo coś blokuje JavaScript.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Kate pewnie opisywała takie okienko bo pasuje do opisu:  ...

 

takie coś rzeczywiście

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Ja też to widzę czasami i tylko w określonej sytuacji = Wasza sesja na forum wygasła, zbyt długo byliście nieaktywni i przestaliście być traktowani jako "online". Wystarczy odświeżyć stronę. To zachowanie jest od początku, od pierwszej wersji forum z wbudowanym CKEditorem.

To nie jest związane z przerobieniem treści posta na znaczniki HTML.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dzięki za wytropienie. Poprawimy to (notatki moderatorskie zostawiane przy edycji).

 

EDIT: konwersja wykonana. Wszystkie notatki powinnny być prawidłowe.

Edytowane przez picasso

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

może to nie błąd ale są małe krzaczki w spoilerze tematu https://www.fixitpc.pl/topic/8870-naprawa-reset-katalogu-sieciowego-winsock/

 

walka z krzaczkami znalezionymi w cytatach https://www.fixitpc.pl/topic/16730-powolne-dzialanie-polaczenia-internetowego/

 

błąd z linkiem https://www.fixitpc.pl/topic/15304-ci%C4%85g%C5%82y-b%C5%82%C4%85d-program-eksplorator-windows-przesta%C5%82-dzia%C5%82a%C4%87/

 

błąd w codepain https://www.fixitpc.pl/topic/16365-blad-aktualizacji/ https://www.fixitpc.pl/topic/16374-problem-przy-wylaczaniu-komputera/

 

krzaczki w czystym tekscie https://www.fixitpc.pl/topic/16250-win32-sirefef-mppt97shallcode0-i-wiele-innych/

https://www.fixitpc.pl/topic/13802-piec-wystapien-bledu-0xc0000035-win-8/

 

mam szukać dalej bo jest tego jeszcze pełno z 10 do entej stron po użyciu google z prawidłowym winikiem

chyba ręcznie to tej konwersji nie da się sokro to chwyciło stare i świeższe wątki

 

mogę wygenerować jeszcze jakieś wyszukiwania na wypadek znalezienia czegoś jeszcze choć nie wiem co tam wpisać bo nie wiem jak szybko google zakualizuje wyszukiwarkę i wyniki nie będą przekłamywać

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Wielkie dzięki za trud włożony w szukanie krzaków. Wszystko poprawię. Widzę, że dużo wyników tyczy po prostu zamknięć cudzysłowu w wersji graficznej dolny-górny „” oraz dwa górne pojedyncze ‘’ (a nie dwa górne podwójne ""). Pozostałe to już mniejsze drobnostki: znak temperatury, kreska – (w odróżnieniu od -), krzyżyk × (w odróżnieniu od x), znaki ® ™, kropka • oraz jakieś dziwne spacje przekonwertowane na śmieci. Trzeba będzie zapuścić na wszystkie tabele nowe komendy zamiany znaków.

Wyjątkiem jest ten pierwszy cytat z tematu Winsock, o nim wiem. Już wcześniej po konwersji poprawiłam tam część, ale zastopowałam i zostawiłam resztę, gdyż się zawahałam czego to pochodna. Ten szczególny blok z tekstem był przeklejany z okna CMD i już w momencie przeklejania były krzaki (to normalne). Nie mogę sobie przypomnieć czy pisząc temat wszystko wtedy ręcznie skorygowałam, dlatego zostawiłam sobie próbkę porównawczą. O ile też mnie pamięć nie myli, na forum były posty w których krzaki były przed konwersją, jako norma przeklejania z okien CMD, i te krzaki nie są związane z naszym tematem.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

U mnie to nie występuje ani z poziomu Opery ani innych przeglądarek. Jaką masz wersję Opery?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Suchy203

Tylko że w tym konkretnym obszarze już była konwersja. I ja tego nie widzę na żadnej przeglądarce. Czy przypadkiem nie oglądasz nieświeżej wersji strony na Operze (niewyczyszczone cache)?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Przejechałem CCleanerem i dalej mam ten kwadracik. A opera najnowsza 12.15

Edit: Teraz zauważyłem, że po każdej dużej literze Ł mam taki kwadracik, więc coś tu u mnie nie trybi.

post-33-0-81149800-1367431347_thumb.jpg

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Litery Ł były konwertowane, ja nie widzę tego w najnowszej Operze. Czyściłeś cache CCleaner, ale:
- zrób to w opcjach Opery (Preferencje > Zaawansowane > Historia > Opróżnij teraz)
- dodatkowo SHIFT+Odśwież na stronie.
Podaj wyniki czy nadal to widać...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...