Skocz do zawartości
reptile

Problem z Internetem w trybie normalnym Windows XP

Rekomendowane odpowiedzi

Witam wszystkich forumowiczów, mój problem polega na tym, że w trybie normalnym Windows XP Pro obecnie SP2 nie otwiera stron WWW - sieć natomiast działa, gdyż pliki z aktualizacji automatycznej pobiera i instaluje, gadu gadu v.10 też działa, lecz każdą stronę internetową (np. www.google.pl) w Firefox czy IE cały czas w pasku statusu jest napisane, że (np. w FF) "Oczekiwanie na www.google.pl...".

 

Natomiast w trybie awaryjnym z obsługą sieci wszystko działa - wyświetla strony WWW.

 

Problemy te zaczeły się pojawiać od czasu gdy pojawiały się problemy, iż program Picasa 3 uruchamiał się z błędem typu zajętości pamięci przez tenże program na danym dysku. Myślałem, że zwolnienie pamięci w jakiś sposób poprawi wydajność tej aplikacji i błąd już nie będzie się pojawiał.

 

W związku z tym zrobiłem następujące kroki: otawrłem Właściwości systemu -> Zaawansowane -> Zmienne środowiskowe i wyedytowałem w Zmiennych użytkowniaka oraz Zmiennych systemowych zmienne TEMP i TMP z dysku, partycji C:\ na F:\ i jeszcze zastosowałem w CMD chkdsk c: /F (to polecenie znalazłem gdzieś w internecie które miało sprawdzić mój system) no ale po ponownym uruchomieniu strony internetowe nie uruchamiały się, więc użyłem systemowej płyty Windows XP Professional z poleceniem R-napraw, ale nic to nie dało.

 

W związku z tym, iż nie chcę formatować systemowej partycji, używając innego komputera zgłaszam się z wielką prośbą do Was drodzy forumowicze o pomoc w rozwiązaniu Tego problemu.

Jeśli by okazało się, że w złej kategorii zamieściłem ten temat, to proszę o jego przesunięcie.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu: klik.

Do zainstalowania Service Pack 3 i Internet Explorer 8, nawet jeśli nie korzystasz.

 

Wywal Bonjour od Apple (czasami sprawia problemy) i Ask Toolbar (to jest śmieć).

Restart komputera.

Do wykonania z wiersza poleceń:

NETSH int ip reset C:\resetlog.txt

NETSH winsock reset

Restart komputera.

 

Pokaż na forum zawartość C:\resetlog.txt

 

Korzystasz z serwera Apache?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

ściągnij sobie Public DNS Server Tool - uruchom i w drugiej tabelce wybierz Google DNS, potem kliknij na Change. po restarcie powinno pomóc.

 

mnie pomogło, a problem był identyczny :)

 

(to polecenie znalazłem gdzieś w internecie które miało sprawdzić mój system)

 

naprawić tak, ale tylko i wyłącznie błędy na dysku systemowym!!!

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

ściągnij sobie Public DNS Server Tool - uruchom i w drugiej tabelce wybierz Google DNS, potem kliknij na Change. po restarcie powinno pomóc.

 

mnie pomogło, a problem był identyczny :)

+
Natomiast w trybie awaryjnym z obsługą sieci wszystko działa - wyświetla strony WWW.

Hmm...

Ale jeśli błąd to faktycznie złe adresy DNS, to będzie się on objawiał w każdym trybie.

A tutaj coś psuje proces/usługa nie uruchamiana w trybie awaryjnym, najpewniej coś, co wymieniłem wyżej.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Wywaliłem Bonjour od Apple, a Ask Toolbar nie znalazłem :(

Proszę, tutaj zamieszczam zawartość pliku C:\resetlog.txt

 

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{6EF3D11F-927B-4E1E-B729-4D81CCC1D17B}\IpAutoconfigurationAddress

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{6EF3D11F-927B-4E1E-B729-4D81CCC1D17B}\IpAutoconfigurationMask

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{6EF3D11F-927B-4E1E-B729-4D81CCC1D17B}\IpAutoconfigurationSeed

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{94636A10-F6F5-4023-9C2F-22CC8175F0BF}\IpAutoconfigurationAddress

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{94636A10-F6F5-4023-9C2F-22CC8175F0BF}\IpAutoconfigurationMask

deleted SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{94636A10-F6F5-4023-9C2F-22CC8175F0BF}\IpAutoconfigurationSeed

<completed>

Tak, korzystam z serwera Apache. ;)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

ściągnij sobie Public DNS Server Tool - uruchom i w drugiej tabelce wybierz Google DNS, potem kliknij na Change. po restarcie powinno pomóc.

 

Witaj DragonFire, dzięki za odpowiedź, lecz tak jak napisał DawidS28:

 

jeśli błąd to faktycznie złe adresy DNS, to będzie się on objawiał w każdym trybie.

 

Sprawdzałem - rzeczywiście nie działa! :(

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Osobiście wywaliłbym wszystko sieciowego od Apple (miałem przejścia z tą firmą), potem na próbę dezaktywował Apache, a jeśli to nie pomoże, to...

Uruchom -> msconfig

 

I z zakładek usługi i uruchamianie wyłączaj po kolei wszystko nie od Microsoftu i po każdym takim zabiegu uruchamiaj sprzęt ponownie i sprawdzaj, czy działa. Możesz wyłączać po kilka na raz.

Nic mi się konkretnego w logach nie rzuca w oczy...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Osobiście wywaliłbym wszystko sieciowego od Apple (miałem przejścia z tą firmą), potem na próbę dezaktywował Apache, a jeśli to nie pomoże, to...

Uruchom -> msconfig

 

I z zakładek usługi i uruchamianie wyłączaj po kolei wszystko nie od Microsoftu i po każdym takim zabiegu uruchamiaj sprzęt ponownie i sprawdzaj, czy działa. Możesz wyłączać po kilka na raz.

Nic mi się konkretnego w logach nie rzuca w oczy...

 

DawidS28 zrobiłem tak jak napisałeś, ale nie pomogło. :( Teraz do Tego jeszcze pojawił się następujący mankament: po uruchomieniu przeglądarki FireFox proces się uruchamia natomiast okno przeglądarki nie.

 

Proszę Was o sprawdzenie i pomoc w naprawie!

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

No i zrobiłem tak jak napisałeś. Z przeglądarką Firefox pomogło :thumbsup:, tylko problem z internetem został. :(

Wyłączyłem wszystkie procesy poza tymi od Microsoftu i teraz się zastanawiam czy wcześniej nie wyłączyły mi się procesy odpowiedzialne za INTERNET, gdyż teraz na tym komputerze mam ok. 27~29 procesów?! :confused:

Czekam na WSKAZÓWKI!

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Procesy i usługi możesz włączyć, problem nie tu.

Wyłącz proxy w Firefoksie i IE.

 

Coś mi zaczyna świtać...

 

@ECHO OFF
CD %SystemRoot%
ECHO Program rozpoczyna dzialanie...
ECHO hosts > \dia-log.txt
CD %SystemRoot% && CD \Windows\system32\drivers\etc
TYPE hosts >> \dia-log.txt
ECHO Etap 1. z 8 zakonczony powodzeniem!
ECHO ipconfig /all >> \dia-log.txt
IPCONFIG /all >> \dia-log.txt
ECHO Etap 2. z 8 zakonczony powodzeniem!
ECHO netstat >> \dia-log.txt
NETSTAT >> \dia-log.txt
ECHO Etap 3. z 8 zakonczony powodzeniem!
ECHO ping -n 10 fixitpc.pl >> \dia-log.txt
PING -n 10 fixitpc.pl >> \dia-log.txt
IF errorlevel 1 GOTO dns [else GOTO nie-dns]
 
:dns
ECHO ping -n 10 194.109.6.97 >> \dia-log.txt
PING -n 10 194.109.6.97 >> \dia-log.txt
GOTO nie-dns
 
:nie-dns
ECHO Etap 4. z 8 zakonczony powodzeniem!
ECHO "tracert fixitpc.pl" >> \dia-log.txt
TRACERT fixitpc.pl >> \dia-log.txt
ECHO Etap 5. z 8 zakonczony powodzeniem!
NETSH int ip reset reset.log
ECHO Etap 6. z 8 zakonczony powodzeniem!
NETSH winsock reset
ECHO Etap 7. z 8 zakonczony powodzeniem!
IPCONFIG /flushdns
IF errorlevel 1 GOTO dns-cli-nie [else GOTO dns-cli-tak]
 
:dns-cli-nie
ECHO Usluga Klient DNS nie jest uruchomiona! >> \dia-log.txt
ECHO Usluga Klient DNS nie jest uruchomiona!
GOTO dns-cli-tak
 
:dns-cli-tak
ECHO Etap 8. z 8 zakonczony powodzeniem!
ECHO "EoF" >> \dia-log.txt
ECHO OPERACJA ZAKONCZONA POWODZENIEM!
ECHO Wygenerowany log dia-log.txt znajdziesz na partycji systemowej.
ECHO Nastapi teraz ponowne uruchomienie komputera.
PAUSE
SHUTDOWN /r /t 1

 

Wklej do notatnika. Zapisz to jako dia-log.bat

Potem ten plik uruchom jak normalny program, poczekaj, aż się wykona. Zatwierdź ponowne uruchomienie systemu i przekopiuj po nim zawartość dia-log.txt do posta. Plik ten utworzy się na dysku C.

 

Program jest udostępniany jako wersja testowa, jeszcze go dokładnie nie sprawdziłem pod różnymi środowiskami.

Powinien działać poprawnie, ale lepiej uważaj.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Wklej do notatnika. Zapisz to jako dia-log.bat. Potem ten plik uruchom jak normalny program, poczekaj, aż się wykona.

 

Wywala mi takie coś:

 

 

 

Nie mogę już zrobić tak jak napisałeś dalej, boo nie generuje się dia-log.txt :(

Co teraz mam zrobić?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Teraz.

Faktycznie, mój błąd.

 

// EDIT

Jednak nie... pracuję nad tym :D

 

// EDIT2

 

Teraz spróbuj ;)

Co z tym proxy?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dzieki, teraz faktycznie aplikacja wygenerowala kod:

 

 

 

Co z tym proxy?

 

W FireFox mam tak:

 

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Co zrobić by INTERNET chodził tak jak dawniej - tylko nie piszcie, bym przeinstalował, bo próbował i nadal nie działa! :confused:

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Co zrobić by INTERNET chodził tak jak dawniej - tylko nie piszcie, bym przeinstalował, bo próbował i nadal nie działa! :confused:

Próbowałeś reinstalacji systemu?

Jeśli tak, to problem leży gdzieś poza oprogramowaniem albo powstaje przez wprowadzone przez Ciebie ustawienia...

 

http://ciekawa-informatyka.pl/programs/dia-log.exe - odpal ten program, koniecznie z trybu normalnego, i postępuj wedle instrukcji.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...