Skocz do zawartości
Pareol

Win 7 HP 64-bit - Błąd podczas instalacji SP1

Rekomendowane odpowiedzi

Witam serdecznie,

 

Proszę o pomoc w zainstalowaniu SP1 na Windows 7 HP 64-bit. Sprawdziłem już SFC /scannow (2 razy dla pewności), nie wykrył błędów. Próbowałem już kilku opcji, ale nie dało się ukończyć instalacji ani przez Windows Update, ani z pliku. Narzędzie gotowości przeszło i nie wykryło błędów w raportach (te dodatkowe CBS...)

Przeglądając forum natknąłem się na porady odnośnie dodania usuniętych plików do folderów WinSXS (ati..., nv...). Pliki te przywróciłem z płyty z systemem, przez co udało się przejść przez instalację SP, ale niestety nie do końca. Po restarcie pojawił się tym razem taki błąd:

ERROR_INSTALL_FAILURE(0x80070643)

Dodam, że instalowałem SP1 w trybie awaryjnym.

 

Dołączam log z CBS

Z góry dziękuję za pomoc

http://speedy.sh/eNSJa/CBS.zip

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

W trybie normalnym trwa to o wiele dłużej i na końcu (po restarcie już) też występuje błąd i system cofa zmiany.

Zastanawiam się nad reinstalką nakładkową, ale jeśli jest jeszcze jakaś szansa normalnej naprawy to wolę najpierw tę opcję.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Przepraszam za post pod postem, ale naprawdę zależy mi na szybkim rozwiązaniu.

Dziś znowu "walczyłem" z SP1 i znowu porażka. Przez WU się nie udało, wystąpił błąd po ponad godzinie. Potem postanowiłem sprawdzić jeszcze raz opcję z płyty. Wcześniej dla pewności sprawdziłem czy ta stumegowa partycja jest ustawiona jako aktywna. Dodatkowo przypisałem jej literę dysku. Po skopiowaniu plików i restarcie komunikat o błędzie i cofanie zmian.

 

SFC /Scannow - bez błędu, Logi CheckSUR i CheckSUR.persist też nie wykazują błędów.

 

Postanowiłem zrobić reinstalkę nakładkową, ale podczas reinstalacji pokazało komunikat: "Nie można wykonać uaktualniania systemu Windows z powodu następujących problemów. Anuluj uaktualnienie, wykonaj poszczególne zadania, a następnie uruchom ponownie uaktualnienie, aby kontynuować.   Nie można zakończyć wymaganego testu zgodności z powodu błędu. Anuluj instalację i spróbuj ponownie uaktualnić." O jaki błąd może chodzić?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Niestety, FixIt z tej strony też nie pomógł. Teraz po restarcie, podczas konfigurowania SP (przy około 9%) znowu wycofuje zmiany. Po kolejnym restarcie pokazuje się błąd 0x800f0826.

Rozwiązanie odsyła do strony MS, na której podpowiada, aby użyć narzędzia analizy gotowości aktualizacji systemu. Tylko, że już je 2 razy odpalałem i te logi nie wykazują błędów...

Czyli pętla bez rozwiązania jak na razie.

Jakieś inne sugestie? Co jeszcze mogę sprawdzić lub naprawić?

 

Tak się zastanawiam, czy nie miesza drugi dysk HDD, na którym też jest aktywna partycja z ubuntu. Może go odpiąć na czas instalacji SP?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Teoretycznie nie powinno mieć znaczenia ale możesz spróbować, a nuż będzie poprawa.

 

A odnośnie tego błędu tutaj był omawiany ten temat o którym pisałeś

 

KLIK

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Czytałem podany temat już wcześniej. U mnie występuje trochę inny problem.

 

Teraz miałem dla odmiany taki błąd: "ERROR_FILE_NOT_FOUND(0x80070002)"

 

Podaję nowy log CBS

http://speedy.sh/925M7/CBS.zip

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

No to ja już nie wiem pomysły mi się skończyły. Może poczekaj i poproś koleżankę picasso o pomoc ona ma większe kompetencje.

Pozdrawiam

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

OK, dzięki.

Droga picasso, proszę o pomoc.

 

Dodam, że ostatnia próba zainstalowania SP1 przez WU niby się powiodła według komunikatu, ale przed zamknięciem systemu konfiguracja dochodzi do ok.10% i robi restart. Później, po restarcie jest komunikat, że konfiguruje SP1 i przy 9% wyświetla info o cofaniu zmian.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Przeglądając forum natknąłem się na porady odnośnie dodania usuniętych plików do folderów WinSXS (ati..., nv...). Pliki te przywróciłem z płyty z systemem, przez co udało się przejść przez instalację SP, ale niestety nie do końca. Po restarcie pojawił się tym razem taki błąd:

 

ERROR_INSTALL_FAILURE(0x80070643)

 

Dodam, że instalowałem SP1 w trybie awaryjnym.

Czy Ty sobie "zgadywałeś" te braki ATI/nVidia w WinSxS czy robota precyzyjna? Poproszę o dokładne dane, które spowodowały uzupełnianie tych konkretnych plików plus informacja jak to uzupełnianie wyglądało. A aktualizowanie w Trybie awaryjnym zwraca błędy, gdyż są niektóre procesy, które nie mogą być prowadzone w Trybie awaryjnym. Kilka adnotacji z CBS.LOG:

 

2013-10-01 17:33:45, Info                  CBS    Failed to get IVssSnapshotMgmt interface. [hrESULT = 0x8007043c - ERROR_NOT_SAFEBOOT_SERVICE]

2013-10-01 17:33:45, Info                  CBS    SQM: Warning: Failed to get System Restore max diff area. The data won't be available. [hrESULT = 0x8007043c - ERROR_NOT_SAFEBOOT_SERVICE]

 

2013-10-01 17:36:47, Info                  CBS    Obtained poqexec from Cbs key. C:\Windows\System32\poqexec.exe /display_progress \SystemRoot\WinSxS\pending.xml

2013-10-01 17:36:47, Error                 CBS    Startup: SafeMode: Safemode entered while needing to process Primitives, rolling back and cancelling the transaction. [hrESULT = 0x80004005 - E_FAIL]

2013-10-01 17:36:47, Info                  CBS    Setting ExecuteState key to: CbsExecuteStateStageDrivers | CbsExecuteStateFlagRollback | CbsExecuteStateFlagDriversFailed

2013-10-01 17:36:47, Info                  CBS    Progress: UI message updated. Operation type: Service Pack. Stage: 1 out of 1. Rollback.

2013-10-01 17:36:47, Info                  CBS    Progress: UI message updated. Operation type: Service Pack. Stage: 1 out of 1. Rollback.

 

CBS.LOG wskazuje, że problem stanowi aktualizacja sterowników:

 

2013-10-01 17:35:45, Info                  CBS    Progress: UI message updated. Operation type: Service Pack. Stage: 1 out of 1. Percent progress: 9.

2013-10-01 17:35:45, Info                  CBS            INSTALL index: 67, phase: 2, result 0, inf: keyboard.inf

2013-10-01 17:35:45, Info                  CBS            INSTALL index: 68, phase: 2, result 0, inf: input.inf

2013-10-01 17:35:45, Info                  CBS            INSTALL index: 69, phase: 2, result 0, inf: usbstor.inf

2013-10-01 17:35:45, Info                  CBS            INSTALL index: 70, phase: 2, result 0, inf: vhdmp.inf

2013-10-01 17:35:45, Info                  CBS            INSTALL index: 71, phase: 2, result 0, inf: 1394.inf

2013-10-01 17:35:45, Info                  CBS            INSTALL index: 72, phase: 2, result 0, inf: nvraid.inf

2013-10-01 17:35:45, Info                  CBS            INSTALL index: 73, phase: 2, result 0, inf: iastorv.inf

2013-10-01 17:35:45, Info                  CBS            INSTALL index: 74, phase: 2, result 0, inf: amdsata.inf

2013-10-01 17:35:45, Info                  CBS            INSTALL index: 75, phase: 2, result 0, inf: hpsamd.inf

2013-10-01 17:35:46, Info                  CBS            INSTALL index: 76, phase: 2, result 0, inf: volume.inf

2013-10-01 17:35:46, Info                  CBS            INSTALL index: 77, phase: 2, result 0, inf: sbp2.inf

2013-10-01 17:35:46, Info                  CBS            INSTALL index: 78, phase: 2, result 0, inf: cdrom.inf

2013-10-01 17:35:46, Info                  CBS            INSTALL index: 80, phase: 2, result 0, inf: usb.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 81, phase: 2, result 0, inf: usbport.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 82, phase: 2, result 0, inf: umbus.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 84, phase: 2, result 0, inf: mchgr.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 85, phase: 2, result 0, inf: iscsi.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 86, phase: 2, result 0, inf: ipmidrv.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 87, phase: 2, result 0, inf: mdmcpq.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 88, phase: 2, result 0, inf: prnms002.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 89, phase: 2, result 0, inf: wpdcomp.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 96, phase: 2, result 0, inf: netrndis.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 102, phase: 2, result 0, inf: bth.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 103, phase: 2, result 0, inf: bth.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 104, phase: 2, result 0, inf: usbport.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 105, phase: 2, result 0, inf: usb.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 106, phase: 2, result 0, inf: usbstor.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 107, phase: 2, result 0, inf: nvraid.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 108, phase: 2, result 0, inf: iastorv.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 109, phase: 2, result 0, inf: amdsata.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 44, phase: 3, result 0, inf: tsgenericusbdriver.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 45, phase: 3, result 0, inf: tsusbhubfilter.inf

2013-10-01 17:35:47, Info                  CBS            INSTALL index: 46, phase: 3, result 3, inf: winusb.inf

2013-10-01 17:35:48, Info                  CBS    DriverUpdateInstallUpdates failed [hrESULT = 0x80070003 - ERROR_PATH_NOT_FOUND]

2013-10-01 17:35:48, Error                 CBS    Doqe: Failed installing driver updates [hrESULT = 0x80070003 - ERROR_PATH_NOT_FOUND]

2013-10-01 17:35:48, Info                  CBS    Perf: Doqe: Install ended.

2013-10-01 17:35:48, Info                  CBS    Failed installing driver updates [hrESULT = 0x80070003 - ERROR_PATH_NOT_FOUND]

2013-10-01 17:35:48, Error                 CBS    Shtd: Failed while processing non-critical driver operations queue. [hrESULT = 0x80070003 - ERROR_PATH_NOT_FOUND]

2013-10-01 17:35:48, Info                  CBS    Shtd: Rolling back KTM, because drivers failed.

2013-10-01 17:35:48, Info                  CBS    Progress: UI message updated. Operation type: Service Pack. Stage: 1 out of 1. Temporary Rollback.

2013-10-01 17:35:48, Info                  CBS    Progress: UI message updated. Operation type: Service Pack. Stage: 1 out of 1. Temporary Rollback.

 

Dostarcz dodatkowy raport C:\Windows\inf\setupapi.dev.log.

 

 

 

.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dziękuję za zainteresowanie moim problemem :)

Jeśli chodzi o przywracanie tych plików do WinSxS to była to raczej metoda precyzyjna. Kopiowałem to z płytki z Windows 7 do tymczasowego folderu, a potem pod ubuntu na miejsce docelowe.

 

Z tym trybem awaryjnym to rzeczywiście nie to. Myślałem, że pomoże.

 

Dla pewności odplaliłem dziś ponownie instalkę SP1 (w normalnym trybie) ze ściągniętego już pliku na dysku. Jak na razie klapa na tych 10 procentach podczas konfiguracji po restarcie.

Podaję aktualne logi.

 

http://przeklej.net/down/747791325495068215621466335093435264f25ae93943736401ed962.html

 

@edit: Poprawiłem link, bo poprzednio coś poszło nie tak (zmieniłem serwis hostowania na inny).

 

@edit 2: System zainstalowany ponownie wraz z dodatkiem SP1, temat do zamknięcia.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...