Skocz do zawartości
spectrumo

Windows Update nie widzi SP3 w systemie

Rekomendowane odpowiedzi

Witam

 

Mam problem z aktualizacjami windows.

 

Postawiłem świeży system za pomocą płyty ze zintegrowanym SP3, którą zmontowałem wg wskazówek jeszcze z searchengines. Wiem, że płyta jest ok, bo już kilka razy stawiałem z niej system. Windowsa stawiałem tak:

- "wyczyściłem" MBR za pomocą fixmbr,

- sformatowałem dysk za pomocą live CD z linuksem (stary Sabayon), zmieniając przy okazji rozmiary partycji,

- zainstalowałem windowsa,

- zainstalowałem sterowniki do laptopa ze strony producenta (Dell Vostro, sterowniki ściągałem za pomocą innego linuksa odpalanego z pendrive - Porteus)

- uruchomiłem SeconfigXP,

- zainstalowałem IE8, którą wcześniej ściągnąłem z sieci (linuks Porteus),

- wrzuciłem Avast Internet Security (wersja z promocji, licencja do kwietnia 2011)

- zainstalowałem jeszcze Firefoxa, Thunderbirda, WTW (wszystkie ściągnąłem wcześniej za pomocą linuksa)

- podpiąłem się do sieci przez wifi

- aktywowałem system.

I teraz pojawił się problem. Chciałem uruchomić Windows Update, żeby zaktualizować system. Ponieważ mam słabe łącze i limity danych ustawiłem sobie w opcjach, żeby XP tylko informował o dostępności aktualizacji, które zamierzałem pobierać ręcznie późnymi wieczorami, bo wtedy net mi lepiej działa. Niestety WU przekierowuje mnie na stronę gdzie zamiast aktualizacji mam jedynie możliwość ściągnięcia i zainstalowania SP3, który mam już w systemie. Historię w przeglądarce wyczyściłem, choć nie wchodziłem na nic poza windows update. Przełączyłem też aktualizacje na automatyczne, ale bez efektu, w związku z czym powróciłem do informowania bez pobierania. Pobieranie ręczne takiej masy aktualizacji trochę mnie przeraża, zwłaszcza, że musiałbym je wyszukiwać na stronie Microsoftu po dacie opublikowania - Windows Update pokazuje mi tylko SP3, a ten przecież w systemie już jest. Ściągać go i instalować jeszcze raz?

Nie mam koncepcji do dalej robić.

 

W załącznikach logi.

OTL.Txt

Extras.Txt

FireGen.txt

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu: klik.

:ph34r: spectrumo;

Ściągać go i instalować jeszcze raz?

Tak - SP zawiera łatki nieudostępniane w Windows Update.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Karolek:

 

Tak - SP zawiera łatki nieudostępniane w Windows Update.

 

Nie wczytałeś się w problem:

 

Postawiłem świeży system za pomocą płyty ze zintegrowanym SP3 (...) Windows Update pokazuje mi tylko SP3, a ten przecież w systemie już jest

 

A log z OTL pokazuje status systemu:

 

Windows XP Professional Edition Dodatek Service Pack 3 (Version = 5.1.2600) - Type = NTWorkstation

Internet Explorer (Version = 8.0.6001.18702)

SP3 już jest w tym systemie.

 

 

spectrumo

 

Postawiłem świeży system za pomocą płyty ze zintegrowanym SP3 (...) Niestety WU przekierowuje mnie na stronę gdzie zamiast aktualizacji mam jedynie możliwość ściągnięcia i zainstalowania SP3, który mam już w systemie.

 

Na początek pokaż jakie dane nosi aktualnie rejestr.

 

Start > Uruchom > regedit i w kluczu:

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows

 

Popatrz na wartość CDSVersion czy ona w hexie jest równa 300 (co odpowiada posiadaniu SP3).

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion

 

Zaś w tym kluczu po kolei mi przepisz co widzisz w CDSVersion, CurrentBuild, CurrentBuildNumber, CurrentVersion.

 

 

 

 

.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Start > Uruchom > regedit i w kluczu:

 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows

 

Popatrz na wartość CDSVersion czy ona w hexie jest równa 300 (co odpowiada posiadaniu SP3).

 

CSDVersion: REG_DWORD 0x00000300 (768)

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion

 

Zaś w tym kluczu po kolei mi przepisz co widzisz w CDSVersion, CurrentBuild, CurrentBuildNumber, CurrentVersion.

 

CSDVersion: REG_SZ Dodatek Service Pack 3

CurrentBuild: REG_SZ 1.511.1 ()(Obsolete data - do not use)

CurrentBuildNumber: REG_SZ 2600

CurrentVersion: REG_SZ 5.1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Póki co, wartości poprawne. W tym drugim kluczu zapomniałam dodać do sprawdzenia: BuildLab.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

BuildLab: 2600.xpsp.080413-2111

 

Przypomniałem sobie coś, co może być pomocne. Przed instalowaniem sterowników support Della każe zainstalować coś, co nazywa się Notebook System Software i zawiera m. in. jakieś poprawki do Windowsa. Podczas poprzedniej instalacji NSS Della miał wersję chyba A27, teraz zainstalowałem A30, czyli nowszą. Może tu tkwi problem, skoro wcześniej udało mi się zainstalować i zaktualizować system bez przeszkód?

 

NSS Fixes and Enhancements (wg strony Della):

1. Fix for issue documented in Microsoft Knowledgebase article KB895953: Memory leak in Windows XP Tablet PC Edition.

2. Fix for issue documented in Microsoft Knowledgebase article KB900722: Ink programs may close unexpectedly in Windows XP Tablet PC Edition 2005.

3. Fix for issue documented in Microsoft Knowledgebase article KB920295: The mouse pointer or pen pointer behavior is irregular in Windows XP Tablet PC Edition 2005.

4. Fix for issue documented in Microsoft Knowledgebase article KB922006: The stylus pen may no longer work after you install a hotfix for Windows XP Tablet PC Edition 2005.

5. Updated to latest version of Microsoft hot fix: KB896256 (Windows XP SP2).

6. Updated to latest version of Microsoft SDIO hot fix: replace KB934428 with KB946629. (Windows XP SP2).

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Ten build się zgadza z posiadaniem gołego SP3 RTM bez żadnych hotfixów zaaplikowanych. To może z innej strony, czyli aktualizacja Windows Update Agent dostępnego do pobrania m.in. z artykułu: KB949104.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Zainstalowałem WUA i działa. Były po drodze małe problemy z avastem, ale udało mi się je pokonać. Zastanawiam się, czy cała ta szopka nie była spowodowana przez Avasta.

 

Mam jeszcze kilka pytań. Czy w trakcie aktualizacji mogą pojawić się dwa procesy wuauctl? W folderze WINDOWS\system32 mam dwa pliki: wuauclt.exe i wuauclt1.exe. Który z nich odpowiada za proces aktualizacji? Wydaje mi się, że jeden powstał po instalacki WUA z pliku. Dobrze myślę?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Zastanawiam się, czy cała ta szopka nie była spowodowana przez Avasta.

 

Trudno mi to ocenić, ale powątpiewam w ten scenariusz, gdyż aktualizacja Windows Update Agent pomogła (co kieruje po prostu na problem zbyt starych plików).

 

 

W folderze WINDOWS\system32 mam dwa pliki: wuauclt.exe i wuauclt1.exe. Który z nich odpowiada za proces aktualizacji? Wydaje mi się, że jeden powstał po instalacki WUA z pliku. Dobrze myślę?

 

Ten dubel jest normalny. Tak, drugi plik jest generowany, jeśli następuje aktualizacja mechanizmu Windows Update.

 

 

.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Poprzedni temat 'Windows Update nie widzi SP3 w systemie' został zamknięty a ja miałem podobny problem.

 

Oryginalny Windows XP home SP3 pl, dysk po formacie, świeżutka (przed sekundą zakończona) standardowa instalacja.

 

Przy próbie update-u dostaję link: http://support.microsoft.com/kb/2497281

 

Windows przedstawia się jako XP sp 3, a w powyższym linku jest napisane, że nie mam dostępu jeśli nie zaktualizuję swojego XP ?!?

 

Żeby się upewnić, że czegoś nie namieszałem, zrobiłem raz jeszcze format i raz jeszcze zainstalowałem xpeka i dalej to samo.

 

Dopiero porada Picasso pomogła:

 

aktualizacja Windows Update Agent dostępnego do pobrania m.in. z artykułu: KB949104

 

Więc to raczej chyba jest wina po stronie M$

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Więc to raczej chyba jest wina po stronie M$

 

Ja na to patrzę z innej strony: to Wasze XP są za stare w stosunku do zmian mechaniki Windows Update (która idzie nierównolegle). SP3 to rok 2008 i jest oczywistym, że brakuje tu (wielu) aktualizacji.

Tego problemu nie zanotowałam za to w XP Mode (Windows XP Pro SP3) w Windows 7, obraz MS wykazuje różnice w stanie aktualizacyjnym i ma inny nowszy BuildLab (2600.xpsp_sp3_gdr.090206-1234).

 

Temat doklejam do poprzedniego. Całość (rozwiązane) zamykam.

 

 

.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...