Skocz do zawartości
basiek

Strona Facebooka nie ładuje się

Rekomendowane odpowiedzi

Witam, mam problem z ładowaniem się na laptopie strony Facebooka, czasami przycina się również ładowanie poczty mailowej ( gmail.com). Korzystam z WiFi. System przeskanowałam większością znanych mi programów, ewentualne zagrożenia zostały usunięte. Zmieniłam również DNS na 8.8.8.8 i 8.8.4.4 i dopiero na Waszym Forum wyczytałam, że problem może leżeć w MTU. Zgodnie z instrukcją zawartą na Forum próbowałam wyszukać MTU, które byłoby najlepsze, jednak od wartości 1472 pojawia się komunikat: "Upłynął limit czasu żądania" i dalej jest 100 % straty.

Proszę więc o pomoc i z góry dziękuję.

 

Link do ICSI Netalyzr:

http://n1.netalyzr.i...-e8cf-4e4a-96b6

 

 

Plik net-log:

net-log.txt

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu: klik.

Zmieniałeś MTU dla złego interfejsu, akurat dla pętli zwrotnej, czyli loopback. Nie wiem, czemu ma MTU równe 1500 B. Niech tak będzie, ale domyślnie pod Windows 7 jest 4294967295, czyli pełny zakres unsigned int (maksymalna liczba, jaką można zapisać na 32 bitach bez bitu znaku). Niech tak zostanie, ale pamiętaj o tym.

 

Wpisz z uprawnieniami admina polecenia:

netsh int ip set int 10 mtu=1472

netsh int ip set int 11 mtu=1472

 

Potem uruchom ponownie komputer.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dziękuję, zmieniłam i mam nadzieję, że to już pomoże. :) Czy zmienić również tą wartość MTU odpowiednią dla Windowsa 7? Dzięki raz jeszcze. :)

 

 

13.58

Już się nacieszyłam. :( Po niespełna pół godzinie "bycia" na stronie Facebooka, strona zawiesiła się na nowo, a po odświeżeniu pojawił się standardowy komunikat : "Błąd wczytywania strony. Połączenie zostało zresetowane ... " Jaki jeszcze może być powód? :/

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Czy zmienić również tą wartość MTU odpowiednią dla Windowsa 7?

 

Nie znam żadnej możliwości, żeby obecne ustawienie mogło w jakiś sposób zaszkodzić. Niech zostanie. I tak dotyczy tylko komunikacji do localhost, a nie normalnych połączeń z Internetem.

 

Co do głównego problemu: ponieważ widzę, że problem z Facebookiem ma dużo użytkowników, to zrobimy diagnostykę dostosowaną pod Facebook.com.

 

Start -> Programy -> Akcesoria -> prawym na: Wiersz poleceń -> Uruchom jako administrator. Wpisz komendy (po każdej naciskając Enter):

 

netsh int ip show int > C:\cmd_log.txt

tracert facebook.com >> C:\cmd_log.txt

nslookup facebook.com >> C:\cmd_log.txt

nslookup facebook.com 8.8.8.8 >> C:\cmd_log.txt

ping -f -l 1444 facebook.com >> C:\cmd_log.txt

ping -f -l 1464 facebook.com >> C:\cmd_log.txt

 

Po wykonaniu poleceń wrzuć jako załącznik C:\cmd_log.txt.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Jeszcze jedno, o którym zapomniałem:

 

pathping facebook.com >> C:\cmd_log.txt

 

Potem do wrzucenia ten sam plik.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Pięknie. Dostawca (albo Twój router) blokuje pakiety ICMP, dzięki czemu nawet nie jestem w stanie ocenić, którędy idzie transmisja do Facebooka. Ponieważ problem dotyczy dziś większej liczby użytkowników, jestem skłonny zaryzykować stwierdzenie, że usterka leży u jakiegoś operatora, przez którego infrastrukturę idą połączenia do Facebook.com.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dostawca jest, że tak powiem, prywatny. Połączenie radiowe. Możliwe, że coś z routerem.

Czy jeśli podepnę laptop pod główny router będzie można jakoś stwierdzić, czy to wina routera z wifi, głównego czy dostawcy? Szczerze to dla mnie czarna magia, ale najwyżej jutro pogonię dostawcę, który uchyla się od wizyty już od poniedziałku ... Wiem, że problem dzisiaj ma większość ludzi mających internet w Playu, jednak u mnie problem jest już ponad 2 tygodnie. ;/

A i zapomniałam, problem zanika, gdy rozłączę i uruchomię na nowo połączenie z siecią bezprzewodową, jakiś czas śmiga, a później to samo.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Czyli to jednak router blokuje ICMP. No cóż...

 

Robimy zatem po kablu tę listę poleceń:

 

tracert facebook.com > C:\cmd_log.txt

ping -f -l 1444 facebook.com >> C:\cmd_log.txt

ping -f -l 1464 facebook.com >> C:\cmd_log.txt

pathping facebook.com >> C:\cmd_log.txt

 

Po wykonaniu komend wrzuć jako załącznik C:\cmd_log.txt.

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Ok, zrób następujący test. Zmień MTU na komputerze na 1500, czyli polecenia:

 

netsh int ip set int 10 mtu=1500

netsh int ip set int 11 mtu=1500

 

Potem uruchom ponownie komputer. Postaraj się poprzez wpisywanie polecenia ping -f -l NNNN facebook.com wyznaczyć najwyższą wartość, którą można wpisać za NNNN, żebyś dostała odpowiedź z Facebooka, a nie komunikat, że pakiet musi być podzielony. Będzie to gdzieś w okolicach 1400 - 1472. Potem podaj mi ją na forum.

 

Oczywiście wszystko po kablu z pominięciem routera. Później zajmiemy się tym, dlaczego blokuje ICMP.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

1372 to wartość, od której widoczna jest odpowiedź ze strony Facebooka.

 

Trochę to trwało ale znalazłam. :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dziwna wartość. Ponieważ dodatkowe 28 B schodzi na nagłówki TCP/IP, to wynikałoby z testów, że odpowiednie dla Facebooka MTU ma wartość 1400 B i takie proponuję też na próbę ustawić. Jest to właściwie najniższa sensowna wartość dla sieci Ethernet, przy niższych straty wydajności zaczynają się stawać dosyć znaczące.

 

Start -> Programy -> Akcesoria -> prawym na: Wiersz polecenia -> Uruchom jako administrator

 

Wpisz komendy:

netsh int ip set int 10 mtu=1400

netsh int ip set int 11 mtu=1400

 

Po ich wykonaniu uruchom ponownie komputer. Sprawdź działanie Facebooka.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Wartości MTU zmienione. Facebook na chwilę obecną śmiga, jednak zwykle wyłączał się po ok pół godz od włączenia, więc go przetestuję. :D Dzięki. :)

 

Jeśli chodzi o router czy może on blokować pakiety ICMP np dlatego, że jest uszkodzony? Mam go ok roku i do tej pory nie było takich problemów. :/

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Raczej nie jest to uszkodzenie, tylko jego świadoma konfiguracja. Najprawdopodobniej przez producenta. Pojawia się zatem pytanie, czy można to zmienić. Z doświadczenia wiem, że jeżeli to jest jakiś tani domowy router, to zazwyczaj się nie da. Jeżeli podaj model routera, to postaram się poszukać dokładniejszej odpowiedzi.

 

Dlaczego przekazywanie komunikatów ICMP jest potrzebne pisałem już w osobnym artykule o MTU (patrz: Czarne dziury Path MTU Discovery):

http://www.fixitpc.p...nsmission-unit/

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Pokaż screeny ze wszystkiego, co masz w Security oraz System tools -> Log i System tools -> Statistics na stronie konfiguracyjnej routera.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

W konfiguracji wszystko jest wyłączone, więc firewall na routerze nie powinien sprawiać żadnych problemów. A jednak...

 

Jak tam Facebook?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Wczoraj strona się nie wieszała nawet po pół godzinie, więc nie jest źle. Dzisiaj nie było jeszcze kiedy sprawdzić, ale wydaje mi się, że powinien już działać. Pięknie dziękuję za ogromną pomoc i poświęcony czas. Jeśli by się coś znowu działo, jeśli mogę będę męczyć dalej. :) Jeśli chodzi o router z WiFi to pewnie rozglądnę się za nowym. :) Dzięki raz jeszcze. :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Ok, w takim razie temat zamykam jako rozwiązany.

 

Gdybyś w przyszłości zastanawiała się nad wyborem modemu, to załóż nowy wątek.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...