Skocz do zawartości

Witamy na forum Fixitpc.pl
Aktualnie przeglądasz stronę jako gość. Jeżeli posiadasz już konto, zaloguj się - w przeciwnym wypadku zarejestruj konto. Rejestracja jest darmowa, prosta i umożliwia pełny dostęp do funkcji forum.
Zdjęcie

Nie działa aplet panelu sterowania Opcje indeksowania


  • Zamknięty Temat jest zamknięty
34 odpowiedzi w tym temacie

#1
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
Postanowiłem sobie włączyć z powrotem indeksowanie plików, lecz aplet Opcje indeksowania nie działa.

Ikonka wygląda jak biała kartka a Opcje indeksowania zmieniło nazwę na Indexing Options Control Panel

Jak to naprawić ? Bez tego nie mam kontroli nad indeksowaniem plików

Załączone miniatury

  • Schowek01.jpg

ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#2
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów

Postanowiłem sobie włączyć z powrotem indeksowanie plików, lecz aplet Opcje indeksowania nie działa.


Na jakiej zasadzie było wyłączane uprzednio? Panel sterowania > Programy > Włącz lub wyłącz funkcje systemu Windows > Windows Search? Inny sposób? Czy w services.msc usługa Windows Search jest aktywna? W temacie z Realtekiem w rejestrze było to:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowCpl]
"19" = Microsoft.IndexingOptions


Usuwałeś ten wpis z rejestru przed włączeniem indeksowania?


Bez tego nie mam kontroli nad indeksowaniem plików


Przy założeniu, że jest to naruszenie "wizualne" w Panelu sterowania, z klawiatury kombinacja klawisz z flagą Windows + R i wklep komendę control /name Microsoft.IndexingOptions



.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#3
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
Tak usuwałem ten wpis. Indeksowanie wyłączyłem pierw w Sunrise Seven a potem w "Włącz lub wyłącz funkcje systemu Windows > Windows Search"

Wklepanie komendy nie pomaga a Usługa indeksowania jest aktywna. Usługi Windows Search nie ma na liscie
ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#4
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów

Wklepanie komendy nie pomaga a Usługa indeksowania jest aktywna. Usługi Windows Search nie ma na liscie


Chwileczkę, o którym indeksowaniu mówisz? Windows Search jest nowym indeksowaniem i to co jest w Panelu sterowania to aplet tej funkcji. Natomiast obiekt o nazwie "Usługa indeksowania" to jest stary wsteczny system, domyślnie nieaktywny w Windows 7, nie posiada takiego apletu. Oba typy indeksowania są włączane via Panel sterowania > Programy > Włącz lub wyłącz funkcje systemu Windows. By mieć działające indeksowanie nowego typu z apletem tam: Windows Search zaznaczone ale odznaczona Usługa indeksowania. Domyślne ustawienia systemu:

Dołączona grafika



.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#5
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
Zrobiłem tak jak napisałaś, ale ten aplet dalej nie działa :(
ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#6
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów
Na początek ustalmy fakty: aktualnie działa Windows Search a nie Usługa Indeksowania w services.msc?

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#7
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
w services.msc w ogóle niema na liście usługi Windows Search
ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#8
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów
Czyli: Windows Search jest na pewno włączone w interfejsie "Włącz lub wyłącz funkcje systemu Windows", po operacji aktywacji wykonany restart, a usługi nie ma? Przypuszczalny powód niedziałania apletu.

1. Import do rejestru pod kątem rekonstrukcji usługi:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WSearch]
"DisplayName"="@%systemroot%\\system32\\SearchIndexer.exe,-103"
"ErrorControl"=dword:00000001
"ImagePath"=hex(2):25,00,73,00,79,00,73,00,74,00,65,00,6d,00,72,00,6f,00,6f,00,\
74,00,25,00,5c,00,73,00,79,00,73,00,74,00,65,00,6d,00,33,00,32,00,5c,00,53,\
00,65,00,61,00,72,00,63,00,68,00,49,00,6e,00,64,00,65,00,78,00,65,00,72,00,\
2e,00,65,00,78,00,65,00,20,00,2f,00,45,00,6d,00,62,00,65,00,64,00,64,00,69,\
00,6e,00,67,00,00,00
"Start"=dword:00000002
"Type"=dword:00000010
"Description"="@%systemroot%\\system32\\SearchIndexer.exe,-104"
"DependOnService"=hex(7):52,00,50,00,43,00,53,00,53,00,00,00,00,00
"ObjectName"="LocalSystem"
"ServiceSidType"=dword:00000001
"RequiredPrivileges"=hex(7):53,00,65,00,43,00,68,00,61,00,6e,00,67,00,65,00,4e,\
00,6f,00,74,00,69,00,66,00,79,00,50,00,72,00,69,00,76,00,69,00,6c,00,65,00,\
67,00,65,00,00,00,53,00,65,00,4d,00,61,00,6e,00,61,00,67,00,65,00,56,00,6f,\
00,6c,00,75,00,6d,00,65,00,50,00,72,00,69,00,76,00,69,00,6c,00,65,00,67,00,\
65,00,00,00,53,00,65,00,49,00,6d,00,70,00,65,00,72,00,73,00,6f,00,6e,00,61,\
00,74,00,65,00,50,00,72,00,69,00,76,00,69,00,6c,00,65,00,67,00,65,00,00,00,\
53,00,65,00,41,00,73,00,73,00,69,00,67,00,6e,00,50,00,72,00,69,00,6d,00,61,\
00,72,00,79,00,54,00,6f,00,6b,00,65,00,6e,00,50,00,72,00,69,00,76,00,69,00,\
6c,00,65,00,67,00,65,00,00,00,53,00,65,00,49,00,6e,00,63,00,72,00,65,00,61,\
00,73,00,65,00,51,00,75,00,6f,00,74,00,61,00,50,00,72,00,69,00,76,00,69,00,\
6c,00,65,00,67,00,65,00,00,00,53,00,65,00,54,00,63,00,62,00,50,00,72,00,69,\
00,76,00,69,00,6c,00,65,00,67,00,65,00,00,00,00,00
"FailureActionsOnNonCrashFailures"=dword:00000001
"DelayedAutoStart"=dword:00000001
"FailureActions"=hex:80,51,01,00,00,00,00,00,00,00,00,00,03,00,00,00,14,00,00,\
00,01,00,00,00,30,75,00,00,01,00,00,00,30,75,00,00,00,00,00,00,00,00,00,00


Dodatkowo, na wszelki wypadek podaję porównawczy import na rozszerzenie apletu:

Spoiler


2. Sprawdź czy plik C:\Windows\system32\SearchIndexer.exe jest na dysku. Wywołaj komendę sfc /scannow, przefiltruj CBS.LOG do wystąpień znaczników [SR] i zaprezentuj raport: KLIK.



.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#9
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
Tego 2 klucza i tak nieda się dodać do rejestru wyskakuje błąd Dołączona grafika

Tego pliku nie znalazłem, czyli go niema

przefiltruj CBS.LOG do wystąpień znaczników [SR] i zaprezentuj raport


Nic z tego nie rozumiem :/ co mam zrobić, czym i gdzie ?
ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#10
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów
To kolejny raz, gdy nie czytasz uważnie i to mnie już zaczyna lekko irytować.

Tego 2 klucza i tak nieda się dodać do rejestru wyskakuje błąd


Wróć do spoilera i przeczytaj adnotację spodnią.

Nic z tego nie rozumiem :/ co mam zrobić, czym i gdzie ?


Wszystko opisane w linku. Otworzyłeś chociaż? Podana komenda do wklepania w cmd oraz jak zrobić log filtrowany kolejną komendą.



.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#11
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
Weszłem na link, zrobiłem tak jak mówiłaś, przejąłem go na własność i dałem na Pełna kontrola i nie można nadal dodać tego klucza. Plik SearchIndexer.exe już mam, koleżanka podesłała mi go na AQQ
ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#12
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów

Weszłem na link, zrobiłem tak jak mówiłaś, przejąłem go na własność i dałem na Pełna kontrola i nie można nadal dodać tego klucza


Widocznie nie zrobiłeś tego rekursywnie na podklucze. Ale na razie to zostaw, to był poboczny import porównawczy (gdyż obecność obiektu w Panelu sterowania raczej sugeruje, że ten fragment rejestru istnieje i ma się dobrze), dlatego go schowałam w spoilerze.

Istotniejszym jest kompletny brak pliku usługi Windows Search, bez czego indeksowanie działać nie będzie. Nie wiadomo ile jeszcze brakuje, ten brak ikony + opisu apletu może świadczyć, że brak lub naruszony plik DLL tam specyfikowany. Jak mówiłam: komenda sfc /scannow, po jej ukończeniu robisz log filtrowany i go tu podajesz do oceny. Notabene, teraz się przekonasz o przydatności SFC, na które chciałeś robić zamach.

EDIT:

Plik SearchIndexer.exe już mam, koleżanka podesłała mi go na AQQ


SFC nadal aktualny. Koleżanka nie sprawdzi Ci poprawności plików.

,

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#13
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
SFC oczywiście robię, wracając do 2 klucza, na podklucze też robiłem i bez skutku

Aplet już działa, usługa też. Zaraz zrobię log
ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#14
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów

wracając do 2 klucza, na podklucze też robiłem i bez skutku


A ja sądzę, że coś jest nie zresetowane. Lecz jak mówię, to na razie odpuść, z powodów podanych powyżej. Tu Ci na obrazku pokażę jak to wyglądać ma:

Dołączona grafika

Jeśli tak masz, to import nr 2 zbędny.

EDIT:

Aplet już działa, usługa też. Zaraz zrobię log


Dodałeś ten fragment. SFC było wykonane przed tym?


.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#15
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
Zrobiłem sfc oto LOG
W trakcie działania dodałem brakujący plik który mi podesłała koleżanka, może dlatego na przełączniku SR jest pusto.
Jak w opcjach indeksowania przywrócić wykluczone z indeksowania foldery?

Dodałem dysk C do indeksowania i są tam systemowe foldery wykluczone z indeksowania
ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#16
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów

Zrobiłem sfc, log po filtrowaniu na SR jest pusty.
W trakcie działania dodałem brakujący plik który mi podesłała koleżanka, może dlatego na przełączniku SR jest pusto.


Te teorie do kosza. SFC zawsze nagrywa [SR], nawet jeśli nie ma żadnych błędów. Pusty log = źle filtrujesz. Zapakuj cały C:\Windows\Logs\CBS\CBS.LOG do ZIP i podaj tu link, sama to przefiltruję.

Swoją drogą to błąd, że w trakcie działania narzędzia wstawiałeś równocześnie plik. Takich rzeczy się nie robi, nie podczas działania narzędzia parającego się weryfikacją plików.


Jak w opcjach indeksowania przywrócić wykluczone z indeksowania foldery?

Dodałem dysk C do indeksowania i są tam systemowe foldery wykluczone z indeksowania


Zaznaczyć? Ponadto, domyślnie wcale nie jest ustawione wszystko do indeksowania, więc możliwe że już patrzysz na sytuację domyślną.


EDIT: Znów pisałam nie widząc edycji. Moment na analizę loga. EDIT2: Z raportu SFC wynika, że były uszkodzone pliki Windows Search, w tym m.in. biblioteka srchadmin.dll (to właśnie biblioteka z importu 2 i to co mówiłam: "ten brak ikony + opisu apletu może świadczyć, że brak lub naruszony plik DLL tam specyfikowany") oraz pliki MUI. SFC naprawił i dlatego zaczęło działać. Sama rekonstrukcja usługi (import 1 + wstawienie ręcznie pliku) to było za mało. Inna sprawa to: skąd u Ciebie tyle uszkodzeń?

Potencjalne skutki uboczne: SFC interesował się także jakoby uszkodzonym explorer.exe + uxtheme.dll. Jeśli to były pliki modyfikowane przez Ciebie, aktualnie są przywrócone do postaci domyślnej. Nawiasem mówiąc: nie ma potrzeby bezpośredniego patchowania pliku uxtheme.dll "na rzeźnika", skoro można to zrobić w mniej inwazyjny sposób przez patch w pamięci (i Windows Update nie zniesie modyfikacji). Do tego darmowy UxStyle Core.


.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#17
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
Pewnie Windows Search uszkodził Sunrise Seven jego opcją "Wyłącz usługę indeksowanie plików" zamiast wyłączyć skasował plik. SFC faktycznie mi dupę uratowało, a ja chciałem się go pozbyć. A że niby explorer uszkodzony > działanie SS, włącz możliwość stosowania niecertyfikowanych styli.

Wiem, że domyślnie nie wszystko jest dodane, ale chodzi mi o to jak dodać te wykluczone obiekty oraz dlaczego Windows je wyklucza (kilka już znalazłem i dodałem ręcznie, ale nie wszystkie umiem znaleźć)

Mam kolejny problem,

Dlaczego po restarcie komputera/ lub jego wyłączeniu indeksowanie jest wstrzymane i z wyzerowaną liczbą zindeksowanych plików (Jeśli restart lub wyłączenie nastąpiło podczas pracy indeksowania plików) ? Czy to wina zaznaczonej pozycji MS Search w CCleaner?
ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#18
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów

Pewnie Windows Search uszkodził Sunrise Seven jego opcją "Wyłącz usługę indeksowanie plików" zamiast wyłączyć skasował plik.


Pytam, ponieważ to mi nie do końca wygląda na robotę Sunrise Seven, a przynajmniej nie bezpośrednio. Zbyt obszerne szkody. Nie tylko usługa z rejestru skasowana oraz jej plik z dysku, również pliki Windows Search obecne na dysku SFC sklasyfikował jako uszkodzone (co się zgadza z widokiem apletu). Rzeźnia w Windows Search.


A że niby explorer uszkodzony > działanie SS, włącz możliwość stosowania niecertyfikowanych styli.


To grzebie w uxtheme.dll (i podałam właśnie lepszy zamiennik w postaci UxStyle Core). Explorer.exe pewnie "uszkodzony" przez opcję wymiany mapy bitowej na przycisku Orb.


Wiem, że domyślnie nie wszystko jest dodane, ale chodzi mi o to jak dodać te wykluczone obiekty oraz dlaczego Windows je wyklucza


Tu spis wykluczonych z indeksu: KLIK. Powód wykluczenia zapewne dobry: duża aktywność miejsc, obniżenie wydajności systemu, zaśmiecanie indexu obiektami tymczasowymi. O ile sobie przypominam, sztuczne załączenie którejś z wykluczonych lokalizacji w Users może zacząć zadręczać system. I ja tu bym zostawiła tak jak MS to zaplanował. Wyszukiwanie nadal możliwe w tych miejscach, tylko są nie zindeksowane.

A dodanie wykluczonych, jak mówiłam, zaznaczanie ich po wywołaniu opcji Modyfikuj. W oknie widać, że nie wszystko jest zaznaczone (to właśnie wizualny wyraz wykluczeń). Niektóre z lokalizacji to foldery ukryte, dlatego domyślnie w drzewku są niewidoczne. Te lokalizacje ujawnią się w pełnej krasie, gdy w Opcjach folderów opcje widoku są przekonfigurowane (odznaczone "Ukryj chronione pliki systemu operacyjnego" + zaznaczone "Pokaż ukryte pliki i foldery").

Dołączona grafika



Dlaczego po restarcie komputera/ lub jego wyłączeniu indeksowanie jest wstrzymane i z wyzerowaną liczbą zindeksowanych plików (Jeśli restart lub wyłączenie nastąpiło podczas pracy indeksowania plików) ? Czy to wina zaznaczonej pozycji MS Search w CCleaner?


Czy w CCleaner w Opcjach zaznaczyłeś "Automatycznie czyść komputer podczas startu systemu"? Jeśli tak, odznacz to.



.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#19
Punisher2010

Punisher2010

    Użytkownik

  • Użytkownicy
  • PipPipPip
  • 491 postów
Ta opcja nie była wcale włączana w CCleaner, przesyłam ci konfig ccleanera u mnie Klik
ECS P4M890T-M2, Intel Celeron D 3.20 GHz, 2,5 GB DDR2 533 Mhz GoodRam, Sapphire AMD Radeon HD 5670 512 MB GDDR5 Lite ,Realtek RTL8139/810x Family Fast Ethernet NIC, Samsung SP0842N 80 GB, LG HL-DT-ST DVD-RAM GH22LP20, Fortron 350W FSP 350-60MDN, Windows 8 Pro x64 PL

#20
picasso

picasso

    Administrator

  • Administratorzy
  • 26944 postów
Skoro ta opcja nie jest włączona, to CCleaner nie może mieć związku, bo sprzątanie jest wtedy w trybie ręcznym.

Może Kaspersky (którego posiadanie deklarowałeś w innym temacie) przyczynia się. Tu jest z Google temat z podobnymi objawami (wyzerowany index), gdzie zdiagnozowali sobie użytkownicy przyczynę w McAfee / Bitdefender: KLIK.


.

Użytkownik picasso edytował ten post 04-12-2011 - 15:08
Link poprawiony.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych