Skocz do zawartości
kolo

Dysk zewnętrzny niedostępny (błąd CRC) - próba odzyskania danych

Rekomendowane odpowiedzi

Płyta główna to P5G41T-M/USB3.

Poniżej 2 screeny/zdjęcia: z pierwszego ekranu z opcjami do wyboru i po wciśnięciu F8 - Boot Manual (przepraszam, walnąłem się wyżej z tym F7).

post-14091-0-87510000-1513801416_thumb.jpg

post-14091-0-24910000-1513801427_thumb.jpg

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

No to trochę słabo, bo nie robiłem screenów z każdego etapu, w tym z Rufusa - może źle.

Wybrałem tam ikonkę płyty, ten plik WinPE.iso z odpowiedniego folderu WinFE... Jedyne, co mnie wtedy zastanowiło, to to, że po przejściu procesu do stanu "Gotowe" (w niecałe 2 mniuty) System plików miałem na tym etapie ustawiony - teraz sprawdziłem, co jest alternatywnego dla FAT32 -  jako NTFS. Kiedy byłem przekonany, że na początku ustawiłem FAT32.

Ale dla pewności zgrałem ten plik jeszcze poprzez Rufusa, teraz już pilnując i będąc świadomym, że wybieram FAT32. Czas procesu był identyczny jak wyżej, na koniec zdaje się też mi wskoczyło samo na NTFS - nie wiem czemu, ale za drugim razem już miałem pewność, że wybrałem FAT32. Zamknąłem Rufusa. Wyglądało tak, jakby poszło OK.

 

Tak jak pisałem, narzędzia wszystkie usunąłem. Mam tylko tego pendrive'a (ze zobrazowaną parę postów wyżej zawartością), który jest niby "invalid" i boot menu każe mi go wymienić.

Jeśli w tej sytuacji nie ruszymy bez screena z Rufusa, żebyś miał pewność (może gdzieś zrobiłem jakiś oczywisty błąd, już teraz zgłupiałem), to mogę przejechać cały proces od początku, mając to wszystko na świeżo, już bez zbędnych pytań - zresztą wyżej starałem się to raportować krok po kroku.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Wybrałem w Mobie Live CD opcję "Start directly from a bootable USB drive" i zaraz miałem taki komunikat. Czy to oznacza, że pen jest uszkodzony?

 

Mam jeszcze raz przejść szybko procedurę z obrazem iso, zrobić screen Rufusa dla Ciebie i zmienić USB?

post-14091-0-80660000-1513895324_thumb.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Załączam screeny:

  1. folder sources na pendrive'ie
  2. komunikat po tym, jak chciałem zbootować pena w Mobie Live CD jako administrator (poprzednim razem nie wybrałem tej opcji).

post-14091-0-91730000-1513988880_thumb.png

post-14091-0-39250000-1513988896_thumb.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Przeprowadziłem jeszcze raz całą procedurę. Wszystko się zgadza. 

 

Prosiłem żebyś pokazał ustawienia Rufusa. Nie wiem dlaczego usunąłeś obraz iso przed jego przetestowaniem :)

Wrzucę Ci gotowy obraz iso do pobrania. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

W kwestii wyjaśnienia mojego myślenia, może też ktoś się czegoś na uczy na moim błędzie:

 

Przejrzałem wyżej i Twoja prośba o screen z moich ustawień Rufusa pojawiła się już po tym, kiedy za jego pomocą zgrałem plik na pendrive'a, co zakomunikowałem.

 

Żeby było jasne - nie mam oczywiście o nic pretensji, wręcz przeciwnie - jestem Ci bardzo wdzięczny, że cierpliwie (lub mniej) mnie instruujesz, tak samo jak i innych w tematach obok.

 

Może moja wina, ale nie zakładałem na początku, że mam robić zrzut z ekranu każdego otwartego narzędzia po wybraniu wskazanych opcji. Po prostu leciałem wg Twojej procedury, która jest zrozumiale napisana i tylko sygnalizowałem, jak pod linkami z procedury są jakieś nowsze wersje programów, z dodatkowymi opcjami, inne niż u Ciebie. Także tak było z Rufusem - tzn. zastosowałem się do procedury, nie uważając, że mam robić z tego screena (zrobiłbym i wycofałbym się, gdyby się okazało, że widzę u siebie "innego" Rufusa niż u Ciebie w procedurze, ale był "ten sam").

 

A usunąłem obraz iso z tego nowego dysku przenośnego, bo - raz - założyłem w ciemno, że po Rufusie będę miał prawidłowy plik na pendrive'ie, a - dwa - bo z procedury wywnioskowałem, że właśnie przechodzę do kolejnego etapu, czyli kopiowania dysku, i że skoro mam nowy dysk o takiej samej pojemności jak ten wadliwy (z którego chcę kopiować) - 3TB, to że to jest ten moment - po zgraniu na pena - kiedy mam usunąć to, co zapisałem na nowy dysku. Nie mam pojęcia, jak to się kopiuje posektorowo, ale tu pytanie: czy miałem tego nie usuwać z nowego dysku? Czy nie jest tak, że mam udostępnić co najmniej taką wolną przestrzeń na dysku, jaką ma ten dysk, z którego zgrywam (czyli w moim przypadku oznaczało to usunięcie wszystkiego z nowego dysku)?

 

A ten gotowy obraz iso do pobrania, o którym piszesz, to będzie który etap z procedury? Zgrania tego, co mi wrzucisz, na pendrive'a? Zatem nie muszę sam w swoim środowisku przejść tych wszystkich etapów, od początku do końca?

 

Szczerze mówiąc, to nie wiem, dlaczego nie chce mi zbootować tego pena i nie widzę przeszkód, żebym miał to wszystko szybko zrobić jeszcze raz - choćby żeby dać zrzut tego Rufusa i przekonać się, co jest przyczyną nieudanego bootowania (nie ukrywam, że męczy to mnie - wadliwy pendrive?). Ale jak nie trzeba, żebym jeszcze raz to przechodził, to OK - nie to jest finalnym celem.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

W zakładce Tools w MiniFE jest pozycja: "Test in QEMU" - to bardzo podobny sposób do tego co oferuje Mobalive, z tym, ze przetestuje sam obraz iso. Wtedy będzie wiadomo czy obraz się bootuje. Skoro nie widzisz przeszkód - to zrób wszystko szybko od nowa + zaznacz tę opcję. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Przeszedłem jeszcze raz procedurę do momentu Rufusa.

Nie odłączałem i nie podłączałem ponownie wadliwego dysku, w sensie wciąż jest podłączony do płyty głównej.

 

W Mini-WinFE zaznaczyłem opcję z testowaniem QEMU.

 

Poniżej 2 screeny z QEMU, które obrazują okno ze zmieniającym się widokiem już po zgraniu pliku(-ów) przez Mini-WinPE. Czy te screeny oznaczają, że obraz bootuje się pomyślnie? Zgodnie z poleceniem na jednym z nich, zrestartowałem PC-eta.

 

Teraz jestem w Rufusie. Na trzecim screenie jest zestawienie Twojego okna Rufusa z procedury z tym, co ja mam. Wybrałem ikonkę płyty, a po tym plik WinPE.iso z folderu. Kiedy wybieram iso, to automatycznie wskakuje mi w Systemie plików NTFS. Zatem zmieniam na FAT32 (wg procedury) - za pierwszym razem po naciśnięciu startu wracało mi wtedy do NTFS. Kiedy wybieram FAT32, to zwiększa mi się też Rozmiar jednostki allokacji z 4096 bajtów na domyślne 8192. Mam zostawić tę większą ilość, domyślną? Jestem przed kliknięciem Start w Rufusie. Jak widać też, mam podłączony inny pendrive.

 

Aha, spokojnych i radosnych świąt życzę.

post-14091-0-15110000-1514143964_thumb.png

post-14091-0-51110000-1514143973_thumb.png

post-14091-0-03950000-1514143985_thumb.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Juz na screenie widzę, że obraz bootuje, to, że nie odpala to oczywiście już wina qemu, niemniej obraz jest sprawny. 

Tak, wciśnij start, chociaż zawsze zalecane jest korzystanie z najnowszych wersji narzędzi, teraz Rufus w wersji 2.18 jest, ale to kosmetyka. Po prostu odpal, powinno działać. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Uwierz lub nie, ale znowu mam czarny obraz i komunikat:

 

Invalid system disk

Replace the disk and press any key

_  (migający kursor)

 

Od momentu wklejonego ostatnio screena z Rufusem po prostu klikam Start (przy pokazanych opcjach), czekam aż się proces skończy, widzę "Gotowe", no więc zamykam Rufusa (przecież nie jeszcze raz Start...).

Uruchom ponownie w Starcie lub całkowicie Wyłącz, F8 - Boot menu z screena wcześniej, no i ten powyższy komunikat.

 

W akcie desperacji i szukania odpowiedzi gdziekolwiek (domyślam się, że strzelam kulą w płot):

  • dowiedziałeś, się ze screenów tego, co wcześniej pytałeś (ja nie wiem, o co chodzi oczywiście): "Chcę zobaczyć czy bootujesz się w EFI czy w CSM"?
  • może problemem jest coś oczywistego dla Ciebie, co dla mnie nie jest takie i czegoś nie wykonuję - jakieś odpalanie gdzieś jako administrator (czego nie robię), itp.?
  • przez cały ten proces nigdy nie wchodziłem do biosa, czyli jak rozumiem u mnie DEL z tego zdjęcia z opcjami płyty głównej. Może powinienem?
  • przed chwilą zamieniałem dysk zewnętrzny i pena wejściami USB z przodu, także dawałem pena z tyłu komputera - efekt taki sam.
  • przypominam, że mam Windowsa 7 (Ultimate) - jeśli to ma jakikolwiek wpływ na cokolwiek w tym temacie.

 

Poniżej screen z obecnej zawartości pendrive'a. W folderze sources jest tylko plik boot.wim (czyli tak jak poprzednio).

 

Aha, tym razem narzędzi jeszcze nie wyrzuciłem z dysku...

post-14091-0-65010000-1514164763_thumb.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Do jakiego portu USB podłączyłeś pendrive? To nie jest jakieś gniazdo usb 3.0? 

Zdarzyło mi się tylko kilka przypadków w zyciu, ze na danej płycie jakiś pendrive nie chcicał się bootować mimo iż na innej wszystko było bez problemów. Musisz albo zerknąć na ustawienia w bios wzgledem dyskow usb lub kompletnie na około - skorzystać z narzędzia zwanego

PloP boot manager. Zainstalować go i podczas bootowania z niego wybrać dysk USB.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Chyba jedno jest 3.0, ale drugie raczej 2.0 (ale mogę się mylić). Efekt taki sam tu i tu.

Z 2 opcji wybieram naokoło - chcę uniknąć wchodzenia do biosa, chyba że będę musiał.

Po ściągnięciu i wypakowaniu Plop (czy tam Plpbt) mam problem z wyborem aplikacji, jest to mniej czytelne niż w poprzednich narzędziach. Poniżej screen z otwartym folderem Windows (w Plop), obok w razie czego tekstowy Readme.

Widzę 5 plików exe - który wybrać? Ten ostatni na liście z 'boot' w nazwie?

 

 

post-14091-0-29120000-1514316759_thumb.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Tak zrobiłem, wybrałem plopa.

Wtedy pokazuje mi się menu z pierwszego screena-zdjęcia, wybieram USB.

Przez 2 sekundy coś zaczyna robić, po czym zastyga na etapie ze zdjęcia nr 2. Myślałem, że coś się może dzieje bez oznak na ekranie, ale po 40 minutach stwierdziłem, że chyba jednak nie. Ponieważ z poziomu klawiatury nie można tego plopa wycofać/zamknąć (przynajmniej w tym stanie), więc musiałem wyłączyć komputer głównym włącznikiem/wyłacznikiem. Po ponownym włączeniu znowu mam wybór między systemem Windows a plopem.

 

Tylko jako sugestia: na youtube'ie jest filmik, gdzie autor obchodzi to zablokowanie ("freeze") - w ramach VirtualBox, nie miałem do z tym czynienia - poprzez zmianę z kontrolera USB 2.0 (EHCI) na kontroler USB 1.1 (OHCI). 

Nie wiem, czy to uważasz za rozwiązanie i ewent. gdzie jest takie przestawienie USB w Panelu Sterowania. 

 

 

PS. Pytanie bazowe, bo nie wiem, czy ogarniam, co się teraz dzieje: założywszy, że mi w plopie niedługo pójdzie, to czy ja tę całą część początkowej procedury pt. Kopia nośnika, z wybieraniem dysków itd., zrobię właśnie w środowisku i dzięki temu plopowi, czy teraz tylko sprawdzam/bootuję pendrive'a i zaraz z plopa wyjdę, i dopiero wtedy będę właściwie kopiował?

post-14091-0-83860000-1514336903_thumb.jpg

post-14091-0-03620000-1514336917_thumb.jpg

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Sprawdź na innym kompie tego pena. 

Bios masz najnowszy w kompie? 

 

Można spróbować jeszcze zbootować się bezpośrednio z iso, opisze to wieczorem.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dzień dobry,

 

Przepraszam, że piszę w tym wątku, ale nie chcę zakładać nowego tematu ponieważ jestem w podobnej sytuacji, tzn.próbuję odzyskać dane z dysku SATA i natrafiłem na ten wpis. Wykonałem bootowalny pendrive w środowisku Win 10 wg powyższego poradnika i po uruchomieniu przed WinFe pojawił się DIsk Manager, który wyświetla wszystkie dostępne napędy jako OFFLINE i Read Only. Nic takiego nie ma w poradniku. Domyslam się ,że dysk docelowy trzeba zmienić na możliwość zapisu, ale czy trzeba też tryb dysków zmienić na ONLINE? Wolę się upewnić niż nieodwracalnie namieszać.

 

Proszę usunąć mój post usunąć jeżeli zaśmieca dyskusję i założe wtedy nowy temat.

 

POzdraiwam,

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Założ nowy temat. Na forum panuje zasada: jeden problem - jeden temat.

 

Jest informacja, nawet screen z okna jest. Nie wiem, który to dla Ciebie docelowy. Jeśli ten, z którego chcesz odzyskiwać dane: to chyba logiczne, ze to wlasnie on musi byc jako read-only? Mozliwosc zapisu ma byc na dysku NA KTÓRY wykonujesz kopię. W dmde jest on nazwany wlasnie jako docelowy

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Założ nowy temat. Na forum panuje zasada: jeden problem - jeden temat.

 

Jest informacja, nawet screen z okna jest. Nie wiem, który to dla Ciebie docelowy. Jeśli ten, z którego chcesz odzyskiwać dane: to chyba logiczne, ze to wlasnie on musi byc jako read-only? Mozliwosc zapisu ma byc na dysku NA KTÓRY wykonujesz kopię. W dmde jest on nazwany wlasnie jako docelowy

OK, proszę usunąć, założę nowy temat

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Jeśli to moja kolej na odpowiedź, to:

 

Akurat w tych dniach nie mam możliwości sprawdzenia tego pena na innym kompie, ale to drugi, jaki próbuję, i raczej bym wątpił w ten pierwszy. Ten obecny używany był z kilka razy, pokazuje zawartość po chwili bez żadnych błędów...

 

Kompletnie nic nie wiem o biosie. Właśnie się dowiedziałem z tego pytania, że są jakieś wersje. Także tego. Komputer był składany i system wgrywany ok. 5-6 lat temu, od tego czasu nic się w tym podobnych fundamentalnych kwestiach nie działo. Nawet nie mam pojęcia, czy wersje biosa są dla poszczególnych firm/koncernów i jakby się mogło to aktualizować...

 

Poczekam na ten opis bootowania prosto z iso - albo na inną sugestię.

 

Nie wiedziałem, że po drodze będą takie osłabiające problemy, jeszcze przed przejściem do samego kopiowania...

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Spróbuj wg tego poradnika: 

https://www.raymond.cc/blog/boot-an-iso-directly-from-the-windows-boot-manager/

 

Z tym, że wazna uwaga: 

W mode zamiast Load from memory - zaznacz load from file. 

W innym przypadku będzie trzeba dodać sterowniki do  ram (firadisk), być może windows 8.1 je ma domyślnie, być może nie, nie wiem, wiem, że siódemka kiedyś nie miała. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

OK, wracam do tematu.

Przeczytałem poradnik z linka, chyba ogarniam instrukcję, ale nie byłbym bym sobą bez kilku pytań - zresztą dziś już za późno na zaczynanie tego (jak nie zaprzeczysz/nie odpowiesz do poniższych, to rozumiem, że dobrze myślę):

  • Na drugim screenie w linku - w polu Operating Systems rozumiem, że ustawiam mojego Windowsa 7, tzn. nie to 8.1 Pro, które ściągałem w pierwszym kroku procedury, żeby uzyskać obraz iso?
  • Rozumiem, że w path na tym samym screenie z linka wybieram to (cytując z Twojej instrukcji): "W folderze \Mini-WinFE\WinFE.Project.Output\ będzie plik WinPE.iso."
  • Czy po udanym (mam nadzieję) zbootowaniu powinienem widzieć kolejne kroki z Twojej procedury, tzn. dotyczące Kopia nośnika, od notki z kliknięciem OK?
  • Czy jak dojdę to tego momentu, to mam nadal nie usuwać tych wszystkich narzędzi (obecnie 6,49 GB) z dysku, na który będę kopiował posektorowo (bo tam są)? Nie będzie to zajęte miejsce stanowiło problemu przy kopiowaniu z wadliwego dysku 3TB na dysk 3TB?

 

  • Na marginesie: jak usunąć przy starcie systemu opcję wyboru plopa? (bo i tak już chyba nie jest to potrzebna opcja, a tylko niepotrzebnie wydłuża mi start systemu)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Na drugim screenie widzisz dwie, niezależne od siebie części, obydwie mają klawisz add entry (dodaj wpis). Ciebie interesuje tylko druga część. 

 

Tak 

Tak

A po co je chcesz je teraz usuwać? Skup się na robocie na razie. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...