Skocz do zawartości
Penicylina

Libre office zachowanie kolumny z danymi

Rekomendowane odpowiedzi

Cześć
Prowadzę pewne statystyki w Libre Office. Można powiedzieć, że troszkę się uczę obsługi w Excelu niestety napotkałem na pewien problem przy filtrowaniu danych.
Chciałbym zachować kolumnę podczas filtrowania z danymi z liczbą porządkową. Nie umiem nigdzie na ten temat ciekawego poradnika znaleźć. Może ktoś z was wie jak to zrobić w prosty sposób?

zamieszczam w załącznikach jak to wygląda i o co mi chodzi

image.png image.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

=ROW()-1 Pobierasz funkcją pozycję wiersza, -1 bo masz tytuł kolumny, którego nie numerujesz.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dziękuję za poradnik są tam różne przydatne funkcję dzięki, którym mogę ulepszyć moją listę. Niestety opcja, którą zastosowałem nie działa tak jakbym tego oczekiwał. Numeracja się nie poprawia względem filtrowanych wierszy. Myślę, że to podczas filtracji nie jest możliwe.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Ok, przypuszczam, że nie tylko chodzi Ci o nowe posortowanie w filtrze, ale także wyświetlenie części wierszy i ich numeracja z ukryciem pozostałych wierszy. W takim razie pomoże funkcja SUMY.CZĘŚCIOWE

Czyli to co po wpisaniu w przeglądarkę frazy "Numerowanie przefiltrowanych wierszy". Jeśli czegoś nie znajdujesz w przeglądarce dla Open Office to można wyszukiwać z frazą excel, ponieważ funkcje mają w większości te same nazwy i działają tu i tu.

 

=JEŻELI(B2="";"";SUMY.CZĘŚCIOWE(3;B$2:B2))

 

JEŻELI sprawdza tu czy nie ma pustych komórek. Jeśli w kolumnie którą filtrujesz nie ma pustych komórek to nie potrzeba tego JEŻELI

 

=SUMY.CZĘŚCIOWE(3;B$2:B2)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...