Skocz do zawartości
dragolice

YUMI - Problem z dodaniem Windows 7.

Rekomendowane odpowiedzi

Cześć :)
Zrobiłem sobie pendriva multibootowalnego z pomocą narzędzia YUMI.

Dwa obrazy pobrane ze strony Microsoftu czyli Windows 10 wersja 32 i 64 bitowa poszły ładnie.

Problem pojawia się w momencie gdy chcę dodać Windows 7, tylko obraz był modyfikowany i w tym iso znajdują się wszystkie wersje systemu w dodatku x64 i x32.

Pierwszy problem jaki napotkałem to problem z bootowaniem. Wyskoczył komunikat taki jak na obrazku:

 

Spoiler

2139485.jpeg


Okej, pobrałem sobie narzędzie BCDEdit i zobaczyłem że ścieżki się nie zgadzają i poprawiłem je w tych lokalizacjach:

Spoiler

2139486.jpeg

 

2139487.jpeg

 

2139488.jpeg

 

2139489.jpeg


Ścieżki poprawiłem na takie i się udało, instalator ruszył:
 

Spoiler

2139490.jpeg


Tylko pojawił się następny problem, mianowicie wyskakuje mi błąd odnośnie sterowników:
 

Spoiler

2139491.jpeg


Co jest dziwne, bo jak kliknę przeglądaj to widzę wszystkie dyski pendriva i dysk x: (boot). Ktoś wie może czy coś pominąłem?
 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Edit:  Spróbuj włożyć pendriva do portu USB 2.0. Jak nie pomoże to w BIOSie spróbuj przełączyć tryb  dysku SATA (A)HCI na IDE (lub na Compatible w zależności jak to nazwał producent)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dzięki za odpowiedź :)
Laptop to hp pavilion g6 1050ew i w biosie nie mam takich opcji. Słyszałem, że nawet jak nie ma portów usb 3.0 to odpowiada za 2.0 kontroler od 3.0 i dlatego tak może być.
Jeszcze doczytałem w internecie, że ten komunikat może się pojawić jak został zbootowany instalator, ale już dalej nie widzi dysku z którego to się stało, więc może jeszcze pominąłem jakieś pliki konfiguracyjne gdzie są jakieś ścieżki do innych plików. Musiał bym się zgłębić w procedurę instalacyjną, co po kolei musi dostać instalator, tylko ciężko to ogarnąć 😜
Dziwne jest to, że chce sterownik do obsługi cd/dvd i flash gdy normalnie po kliknięciu przycisku przeglądaj pendrive jest bez problemu odczytywany, widać na nim pliki i katalogi :)
Ma znaczenie to, że pendrive jest sformatowany na ntfs? Windows 10 bootuje normalnie, może z tym 7 ma problem?

 

Tutaj jeszcze obrazek z instalatora, folder multiboot to pendrive, a (X:) boot to chyba ramdisk. Coś tam do tego ramdisku załadowało może faktycznie brakuje tego sterownika? :) Sam już nie wiem...

 

Spoiler

2139540.jpeg


 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Skoro instalator windows 10 działa, to zrób taki trick. Z obrazu instalacyjnego windows 10 wyrzuć plik install.wim/install.esd (w zależności jaki masz, z kompresją .esd czy bez) i wstaw install.wim z obrazu windowsa 7. W Yumi dodaj jako windows 10. Instalator będzie wyglądał jak z dziesiątki a zainstaluje siódemkę. Da się tak przeskoczyć podobny błąd z brakiem sterownika USB 3.0, a tak jest prościej niż dogrywać sterownik. Tym bardziej, że u Ciebie nie wskazuje konkretnie o który sterownik chodzi. Całkiem możliwe, że właśnie o USB 3.0 skoro nośnikiem jest pendrive.

 

Spróbuj też zrobić osobnego bootowalnego pendriva programem rufus, jest bardziej niezawodny niż yumi. Sprawdzisz tak czy to nie wina wadliwego obrazu windows 7.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Sprawdziłem i obydwie wersje systemu Windows 10 mają plik install.wim. W obrazie Windows 7 jest plik install.esd. Muszę najpierw go przekonwertować na wim i potem zamienić, dobrze kombinuję?

 

Edycja:
Zrobiłem tak:

1. Stworzyłem nowy folder i skopiowałem do niego wszystkie pliki z Windows 10 oprócz install.wim.
2. Przeniosłem plik install.esd z folderu od Windows 7/x64/sources/do tego nowego z instalatorem Windows 10 do podkatalogu sources.

3. Zmieniłem nazwę nowego folderu na taką jak była wcześniej używana.
4. Zmieniłem ścieżki bcd do pliku boot.wim tak aby załadował się instalator z nowego folderu (brak katalogu x64).

 



Moim oczom ukazała się lista z wyborem systemów Windows 10. Załączam obrazki:

 

Spoiler

 

2139542.jpeg

 

2139543.jpeg

 

2139545.jpeg

 

2139546.jpeg

 

2139547.jpeg

 

2139548.jpeg

 

Błędu już nie ma, tylko nie pokazuje instalacji Windows 7 :) Coś jeszcze powinienem zrobić, coś pominąłem?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Ręcznie chcesz robić to co by zrobił Yumi? :) Po co zmieniasz ścieżki?

install.wim i instal.esd możesz traktować jako równorzędne, bez konwertowania. Po prostu jedno ktoś skompresował a działa tak samo.

 

Mając obraz .iso windows 10 podmień plik install.wim na ten z windowsa 7. To wszystko. Bez zmieniania ścieżek, bez zmiany nazw. Później przez yumi dodaj nowy obraz i z niego odpal laptop.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Okej, zrobię jak piszesz :) Po prostu trzeba było by nagrywać na nowo całe iso na pendriva :). A tak myślałem, że coś ugram na czasie robiąc to ręcznie, bo pliki już są, wystarczy tylko zamienić i pogmerać w bcd.

Ścieżki w plikach bcd musiałem zmienić ponieważ były to pliki skopiowane z katalogu od Windows 10.
BCD z tego folderu odnosiło się do lokalizacji gdzie faktycznie był Windows 10.
Mi zależało na tym, aby odpalił się system z folderu z Windows 7, w którym były wszystkie skopiowane pliki z Windows 10 tylko z podmienionym install.esd.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Wygląda na to, że się udało :) Dziękuję za poświęcony czas :)

 

2139666

 

Jeszcze krótkie pytanko. W instalatorze Windows 7 była taka opcja jak "Napraw komputer". W tym z 10 też można się jakoś do niej dostać ?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Jeśli jest, to jest naprawa windowsa 10, skoro to instalator windows 10, raczej siódemki nie naprawi, aczkolwiek tego akurat nigdy nie próbowałem. Zawsze można stworzyć dysk naprawy z już zainstalowanego windows 7

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Okej, w takim razie trudno. Dzięki.

 

Mam teraz problem z dodaniem iso od Winowsa XP, w którym jest zawarte 9 różnych instalacji i to wszystko zostało sklejone do kupy przez autora za pomocą programu Easyboot. Yumi szuka bezpośrednio pliku setupldr.bin, niestety nazwy katalogów się zmieniły i nie znajduje go.

Jeśli ktoś jeszcze pamięta dziadka XP i byłby w stanie mi pomóc to opiszę problem bardziej szczegółowo :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...