Skocz do zawartości
Antek

Niepożądane menu po instalacji Win7.

Rekomendowane odpowiedzi

Witam.

W komputerze, w którym był zainstalowany XP, doinstalowałem Win7 i odtąd start komputera wygląda w ten sposób, że pojawia się menu (jak na obrazku).

Po dokonaniu wyboru, pojawia się kolejne menu (od lat znajome) z możliwością wyboru systemu. Wszystko działa, ale chciałbym usunąć ten wstępny wybór.

Nie wiem co to jest (Grub?) ? Naprawa MBR nic nie daje. EasyBCD też niczego nie zmienia.

Jak to wyciąć?menu.jpg.8a3485c53992199c8cc56d251d3de006.jpg

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

EasyBCD powinien zmienić, opisz jak go używasz. Wersja bodajże 2.2 była darmowa z pełnymi możliwościami.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
1 godzinę temu, giyefiki napisał:

EasyBCD powinien zmienić, opisz jak go używasz. 

Próbuję na różne sposoby z takim samym miernym wynikiem. Z wykasowaniem wpisów i założeniem nowych włącznie.

Możesz podać jak podejść do EasyBCD skutecznie?

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Jeśli używasz windows 7 to uruchom program jako administrator. Wyłącz czasowo programy antywirusowe lub firewalle lub inne blokery jakie posiadasz. Czy nie masz jakiegoś twardego blokera ustawionego, typu mbrfilter?

 

Spróbuj według instrukcji producenta "skip menu" https://neosmart.net/wiki/easybcd/basics/setting-menu-timeout/#Skip_the_boot_menu

lub usunąć niepotrzebne wpisy https://neosmart.net/wiki/easybcd/basics/deleting-entries/

 

Wcześniej zrób kopię https://neosmart.net/wiki/easybcd/basics/bcd-backup-and-restore/

 

Widzę, że najnowsza wersja programu po rejestracji też jest do użytku darmowego.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Dzięki giyefiki za wszystkie wskazówki.
Przed Twoją odpowiedzią zdążyłem zrobić wszystkie możliwe kombinacje w EasyBCD, co skutkowało tym, że straciłem dostęp do Win7, a start XP odbywał się nadal poprzez to wstępne menu.

 

O to co zrobiłem potem:
- wykonałem zrzuty obu systemów;
- zrobiłem WIPE dysku, czyli wyzerowałem cały układ partycji;
- zbudowałem układ partycji na nowo;
- wgrałem tylko XP;
- odbudowałem MBR;
- odpaliłem kompa i ...
pojawiło się to menu z pierwszego postu.

 

Gdzie ono siedzi?
 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Opisz jak odbudowałeś MBR. Z obrazu? Wgrałeś XP rozumiem, że to z obrazu? Czy EasyBCD pokazuje teraz wszystkie pozycje ze screena?

 

Jeśli już masz obrazy i jak widzę niestraszne Ci eksperymentowanie to zobacz program Bootice. Spróbuj process PBR i dla partycji z XP zainstaluj NTLDR, wcześniej robiąc kopię. Powinien podmienić obecne menu.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Wpisanie MBR robiłem w miniTool Partition Wizard, EasyBCD i TestDisk.

EasyBCD nigdy nie pokazywało treści tego obrazka. Pokazuje to co ustawię: XP i Win7.

BootIce próbowałem jedną opcję.

 

Teraz zrobiłem tak:

- Wyzerowałem cały dysk (240GB SSD). Sprawdziłem, był czysty;

- Ustawiłem tylko jedną partycję FAT32 na XP;

- Wgrałem obraz XP przy użyciu image For Linux (Terrabyte);

- XP nie startował, więc przeskanowałem dysk TestDiskiem i zapisałem to co odnalazł;

- Odpaliłem kompa i pokazało się to menu z obrazka, niestety.

Wywołanie pierwszych pięciu opcji z tego menu uruchamia XP.

 

Na dysku jest tylko XP.  Gdzie ten agent siedzi?

Przeszukałem w TotalCmd cały dysk C pod kątem obecności fragmentu tekstu z tego menu i niczego nie znalazł.

Szukał znaków ASCII, ANSI, UNICODE UTF16, UTF8, i xml.

 

Myślę, że diabeł siedzi gdzieś w sektorach, umieszczony tam przy instalacji Win7.

Kiedyś był taki DiskEdit (chyba Symantec), którym można było wiele zrobić bezpośrednio na dysku.

Teraz już chyba to się nie uda.

 

Temat NTLDR jest mi obcy.

Podmiana (z płyty instalacyjnej) NTLDR i NTDETECT.com niczego nie dała.

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Innymi słowy, kliknij: Bootice > process PBR > NTLDR boot record > install

Wybierz odpowiedni dysk i partycję. Z tego co rozumiem masz jeden dysk i obecnie jedną partycję więc będzie ona zaznaczona domyślnie.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Próbowałem wszelkich kombinacji przy użyciu BootIce (w desperacji nawet opcje Grub). Bezskutecznie. 

Poddałem się i na czysty dysk odtworzyłem starszy o kilka miesięcy obraz XP, a Win7 zainstalowałem od nowa.

Wszystko jest teraz w porządku. Tak jak chciałem.

 

Dzięki giyefiki za pomoc.

Temat do zamknięcia.

Pozdrawiam.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi

Jeśli chcesz dodać odpowiedź, zaloguj się lub zarejestruj nowe konto

Jedynie zarejestrowani użytkownicy mogą komentować zawartość tej strony.

Zarejestruj nowe konto

Załóż nowe konto. To bardzo proste!

Zarejestruj się

Zaloguj się

Posiadasz już konto? Zaloguj się poniżej.

Zaloguj się

  • Ostatnio przeglądający   0 użytkowników

    Brak zarejestrowanych użytkowników przeglądających tę stronę.

×
×
  • Dodaj nową pozycję...