Skocz do zawartości

Witamy na forum Fixitpc.pl
Aktualnie przeglądasz stronę jako gość. Jeżeli posiadasz już konto, zaloguj się - w przeciwnym wypadku zarejestruj konto. Rejestracja jest darmowa, prosta i umożliwia pełny dostęp do funkcji forum.
Zdjęcie

Błąd winlogon.exe - zły obraz


  • Zamknięty Temat jest zamknięty
6 odpowiedzi w tym temacie

#1
RobertM15

RobertM15

    Użytkownik

  • Użytkownicy
  • PipPip
  • 51 postów
  • Skąd:Pruszków
Witam,

Windows Media Center przez kilka kolejnych dni wykazywał ociężałość w działaniu, aż ostatecznie przestał się uruchamiać ( żadnej tapety, tylko czarny ekran ).

Wymyśliłem że są to kłopoty z dyskiem i w konsoli odzyskiwania zapuściłem CHKDSK /R /F. Zaowocowało to bezproblemowym uruchomieniem systemu do ekranu logowania, ale po wybraniu użytkownika i wpisaniu hasła ( "trwa ładowanie ustawień osobistych" ) dysk cały czas pracował z rytmicznym dwutaktem jak pociąg jadący po szynach, a system stał jak wryty w nieskończoność ( wytrzymałem godzinę ).
Wydawało się że potwierdza to moją teorię o problemach z HDD, szczególnie że SMART raportował dwa parametry na średnim poziomie, ale nie krytycznym. Następne skanowania CHKDSK, zgrywanie na inny nośnik ważnych plików, i wreszcie udało mi się uruchomić system prawidłowo do samego końca.
W tym miejscu uznałem że można uratować system w całości i za pomocą Paragon Drive Copy Recovery 9.0 SE przeniosłem go na nowy dysk.

Ale kubeł dla ochłody - nowy dysk zatrzymuje ładowanie po pierwszej tapetce z komunikatem winlogon.exe - zły obraz, Aplikacja lub biblioteka DLL C:\WINDOWS\system32\KBDPL1.DLL nie jest poprawnym obrazem systemu Widnows NT. Sprawdź to z dyskietką instalacyjną. Niezależnie normalny boot czy awaryjny.

Zacząłem szperać po sieci i z różnych opisów wynikało iż większość tego typu problemów ( winlogon - zły obraz ) jest związana z infekcjami.
Dlatego też mój post w tym dziale: teraz wydaje mi się bardziej prawdopodobna infekcja.

Reasumując w tej chwili na dysku oryginalnym system się ładuje, ale nie do końca - w pewnym momencie po wpisaniu hasła, gdy widać już pulpit dysk zaczyna pracować jak pociąg na przejeździe, nic nie daje się kliknąć, myszką bez przeszkód można ruszać. W trybie awaryjnym ładuje się bez problemu.
Na nowym dysku winlogon, zły obraz.

Skanowaniu poddałem tylko dysk oryginalny za pomocą płyty OTLPE.

W trybie awaryjnym skanowanie OTL.exe przerywa komunikat: System Windows - Brak Dysku, Exception Processing Message c0000013 Parameters 75b6bf7c 475b6b7c 75b6bf7c.

Proszę o pomoc.

Załączone pliki

  • Załączony plik  OTL.Txt   77.44 KB   217 Ilość pobrań


#2
picasso

picasso

    Administrator

  • Administratorzy
  • 30217 postów
  • Skąd:Holandia
W logu z OTLPE nie widać żadnych oznak infekcji. Temat przenoszę do działu Windows XP.

Ale kubeł dla ochłody - nowy dysk zatrzymuje ładowanie po pierwszej tapetce z komunikatem winlogon.exe - zły obraz, Aplikacja lub biblioteka DLL C:\WINDOWS\system32\KBDPL1.DLL nie jest poprawnym obrazem systemu Widnows NT. Sprawdź to z dyskietką instalacyjną. Niezależnie normalny boot czy awaryjny.

Zacząłem szperać po sieci i z różnych opisów wynikało iż większość tego typu problemów ( winlogon - zły obraz ) jest związana z infekcjami.


"Zły obraz" = ten komunikat jest związany głównie z nieprawidłowościami w plikach (uszkodzenie). Na komunikacie zgłasza się biblioteka związana z obsługą klawiatury "Polski programisty". To sugeruje wymianę nową kopią wyekstraktowaną z SP3. Plik do pobrania: KLIK. Podstaw pliki z poziomu OTLPE. I zobaczymy co tu się będzie działo po tej operacji.



.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#3
RobertM15

RobertM15

    Użytkownik

  • Użytkownicy
  • PipPip
  • 51 postów
  • Skąd:Pruszków
Podmieniłem plik KBDPL1.DLL, przy następnym restarcie napisało że brakuje KBDUS.dll, też podmieniłem, a następnie SFC.DLL i też podmieniłem.
W tym momencie uruchomił się już normalnie, z tym że na ekranie logowania nie mogę wpisać hasła - klawiatura nie działa ( ani normalna, ani USB ) , Num Lock nie reaguje. Za to myszka działa normalnie i system reaguje normalnie na polecenia wydawane myszką.

Czy niedziałająca klawiatura może być objawem tego iż podmienione przeze mnie pliki były w bardzo różnych wersjach?

#4
picasso

picasso

    Administrator

  • Administratorzy
  • 30217 postów
  • Skąd:Holandia

W tym momencie uruchomił się już normalnie, z tym że na ekranie logowania nie mogę wpisać hasła - klawiatura nie działa ( ani normalna, ani USB ) , Num Lock nie reaguje


Może: są jakieś filtry sprzętowe, naruszenie klas w rejestrze, więcej uszkodzeń w plikach związanych z obsługą klawiatury, braki w sterownikach. Pokaż przynajmniej jak to wygląda od strony rejestru: z poziomu OTLPE przekopiuj plik C:\WINDOWS\system32\config\SYSTEM, zapakuj do ZIP i udostępnij do wglądu.

Czy niedziałająca klawiatura może być objawem tego iż podmienione przeze mnie pliki były w bardzo różnych wersjach?


Co to znaczy "w bardzo różnych wersjach"? Jeśli nie pochodzą z SP3, to pliki dostarczę. Ale też się zastanawiam:

W tym miejscu uznałem że można uratować system w całości i za pomocą Paragon Drive Copy Recovery 9.0 SE przeniosłem go na nowy dysk.


... czy nie zrobić ogólnej Reperacji nakładkowej na tym przekopiowanym systemie, ze względu na dziwne ubytki w plikach (i nie jest wiadome co jeszcze jest uszkodzone). Reperacja powinna w teorii uzgodnić sobie wersje plików i nadbudować braki w rejestrze. Wymagania: płyta XP ze zintegrowanym SP3 w edycji Windows Media Center. Płyty takiej ręcznie nie da się stworzyć (przynajmniej w sposób bezbólowy), integrowanie SP3 na źródle Media Center ma skutki uboczne w niepożądanej konwersji edycji do XP Pro.



.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#5
RobertM15

RobertM15

    Użytkownik

  • Użytkownicy
  • PipPip
  • 51 postów
  • Skąd:Pruszków
W takim razie lepiej na wstępie podmienić pliki na ( na pewno ) prawidłowe, a ew. jak to nie wypali to "trza" się będzie zastanowić jednak nad reinstalacją sytemu :( , ponieważ użytkownik na pewno ma płytę systemową z wcześniejszymi Suport Packami ( instalacja o ile pamiętam pochodzi z 2006 roku ).

Jeżeli można to poproszę o pliki KBDUS.dll i SFC.DLL z SP3.

#6
picasso

picasso

    Administrator

  • Administratorzy
  • 30217 postów
  • Skąd:Holandia
1. Zapakowane biblioteki mechanizmu SFC + wszystkie wystąpienia plików kbd*.dll (layouty klawiatury dla różnych języków) + sterownik klawiatury kbdclass.sys: KLIK. Plik kbdclass.sys ma iść do folderu system32\drivers, pozostałe do system32.

2. Czekam jeszcze na wgląd do sprzętowej gałęzi rejestru SYSTEM.

Pomoc jest darmowa, ale proszę rozważ przekazanie dotacji na utrzymanie serwisu.


#7
RobertM15

RobertM15

    Użytkownik

  • Użytkownicy
  • PipPip
  • 51 postów
  • Skąd:Pruszków
Ad.1 Przekopiowałem wg instrukcji, wygląda na to że system działa prawidłowo, klawiatura też.

Ad.2 Część rejestru SYSTEM w linku: KLIK.

Jak to wygląda?

Użytkownik picasso edytował ten post 21-02-2011 - 07:18
21.02.2011 - Działa = nie ma już co dręczyć tematu. Zamykam. //picasso





Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych